aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pycrypto_2.6.1.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-02-06 08:37:15 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-13 18:43:30 +0100
commit11662a48bbc7a1b525daa818ee9be909d3d456cb (patch)
treed0aedbbaad62b1521b7a887932fdbc06e7906c7f /recipes-devtools/python/python-pycrypto_2.6.1.bb
parentdc7595c92f4fb274688a499da0a65740b0345ea9 (diff)
downloadmeta-python2-11662a48bbc7a1b525daa818ee9be909d3d456cb.tar.gz
python-pycrypto: add app to meta-python
move it from meta-security (From meta-openembedded commit: a625494863b70f13ca29b4b0322fbfd5a8a073d9) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pycrypto_2.6.1.bb')
-rw-r--r--recipes-devtools/python/python-pycrypto_2.6.1.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pycrypto_2.6.1.bb b/recipes-devtools/python/python-pycrypto_2.6.1.bb
new file mode 100644
index 0000000..06a0cc4
--- /dev/null
+++ b/recipes-devtools/python/python-pycrypto_2.6.1.bb
@@ -0,0 +1,11 @@
+inherit distutils
+require python-pycrypto.inc
+
+SRC_URI += "file://cross-compiling.patch"
+
+# We explicitly call distutils_do_install, since we want it to run, but
+# *don't* want the autotools install to run, since this package doesn't
+# provide a "make install" target.
+do_install() {
+ distutils_do_install
+}