aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pycparser_2.19.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-27 20:37:45 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:03:50 -0800
commitda918f657c32ff9a5b5d9969604a2e255af473ec (patch)
tree69bbc29f7780e7a7853bf94de9abe3666db77cdd /recipes-devtools/python/python-pycparser_2.19.bb
parent0890fb548d98199da117816b33fdbbf5c6c83547 (diff)
downloadmeta-python2-da918f657c32ff9a5b5d9969604a2e255af473ec.tar.gz
recipes-devtools: merge inc and bb PART IV
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pycparser_2.19.bb')
-rw-r--r--recipes-devtools/python/python-pycparser_2.19.bb19
1 files changed, 16 insertions, 3 deletions
diff --git a/recipes-devtools/python/python-pycparser_2.19.bb b/recipes-devtools/python/python-pycparser_2.19.bb
index 9874273..63c5a68 100644
--- a/recipes-devtools/python/python-pycparser_2.19.bb
+++ b/recipes-devtools/python/python-pycparser_2.19.bb
@@ -1,6 +1,19 @@
+SUMMARY = "Parser of the C language, written in pure Python"
+HOMEPAGE = "https://github.com/eliben/pycparser"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86f1cedb4e6410a88ce8e30b91079169"
+
+SRC_URI[md5sum] = "76396762adc3fa769c83d8e202d36b6f"
+SRC_URI[sha256sum] = "a988718abfad80b6b157acce7bf130a30876d27603738ac39f140993246b25b3"
+
inherit pypi setuptools
-require python-pycparser.inc
-RDEPENDS_${PN} += " \
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-ply \
+ ${PYTHON_PN}-pprint \
${PYTHON_PN}-subprocess \
-"
+ cpp \
+ cpp-symlinks \
+ "
+
+BBCLASSEXTEND = "native nativesdk"