aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pycodestyle_2.5.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-27 20:37:45 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:03:50 -0800
commitda918f657c32ff9a5b5d9969604a2e255af473ec (patch)
tree69bbc29f7780e7a7853bf94de9abe3666db77cdd /recipes-devtools/python/python-pycodestyle_2.5.0.bb
parent0890fb548d98199da117816b33fdbbf5c6c83547 (diff)
downloadmeta-python2-da918f657c32ff9a5b5d9969604a2e255af473ec.tar.gz
recipes-devtools: merge inc and bb PART IV
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pycodestyle_2.5.0.bb')
-rw-r--r--recipes-devtools/python/python-pycodestyle_2.5.0.bb15
1 files changed, 13 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-pycodestyle_2.5.0.bb b/recipes-devtools/python/python-pycodestyle_2.5.0.bb
index ec6c12f..38ed843 100644
--- a/recipes-devtools/python/python-pycodestyle_2.5.0.bb
+++ b/recipes-devtools/python/python-pycodestyle_2.5.0.bb
@@ -1,5 +1,14 @@
-inherit setuptools
-require python-pycodestyle.inc
+
+SUMMARY = "Python style guide checker (formly called pep8)"
+HOMEPAGE = "https://pypi.org/project/pycodestyle"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=01831ddbaf398471da3cc87f5037e822"
+
+SRC_URI[md5sum] = "40e7a76f364a18f531aaba11a4476e21"
+SRC_URI[sha256sum] = "e40a936c9a450ad81df37f549d676d127b1b66000a6c500caa2b085bc0ca976c"
+
+inherit pypi setuptools
RDEPENDS_${PN} += "${PYTHON_PN}-lang"
@@ -8,3 +17,5 @@ do_install_append () {
mv ${D}${bindir}/pycodestyle ${D}${bindir}/pycodestyle-2
fi
}
+
+BBCLASSEXTEND = "native nativesdk"