aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-prompt-toolkit_2.0.10.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-27 20:37:45 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:03:50 -0800
commitda918f657c32ff9a5b5d9969604a2e255af473ec (patch)
tree69bbc29f7780e7a7853bf94de9abe3666db77cdd /recipes-devtools/python/python-prompt-toolkit_2.0.10.bb
parent0890fb548d98199da117816b33fdbbf5c6c83547 (diff)
downloadmeta-python2-da918f657c32ff9a5b5d9969604a2e255af473ec.tar.gz
recipes-devtools: merge inc and bb PART IV
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-prompt-toolkit_2.0.10.bb')
-rw-r--r--recipes-devtools/python/python-prompt-toolkit_2.0.10.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-prompt-toolkit_2.0.10.bb b/recipes-devtools/python/python-prompt-toolkit_2.0.10.bb
index 527c905..13acbc5 100644
--- a/recipes-devtools/python/python-prompt-toolkit_2.0.10.bb
+++ b/recipes-devtools/python/python-prompt-toolkit_2.0.10.bb
@@ -1,6 +1,21 @@
+SUMMARY = "Library for building powerful interactive command lines in Python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
+
+SRC_URI[md5sum] = "5016c523e603cd7119644fbc0f00ce53"
+SRC_URI[sha256sum] = "f15af68f66e664eaa559d4ac8a928111eebd5feda0c11738b5998045224829db"
+
+PYPI_PACKAGE = "prompt_toolkit"
+
inherit pypi setuptools
-require python-prompt-toolkit.inc
RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-six \
${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-wcwidth \
"
+
+BBCLASSEXTEND = "native nativesdk"