aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-prettytable_0.7.2.bb
diff options
context:
space:
mode:
authorMarc Ferland <ferlandm@amotus.ca>2017-05-01 11:32:08 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-05-04 09:18:58 +0200
commit82bae8d33d77d3d3c4a2ce6c27c1fbd8288d5bb1 (patch)
tree7c8039ae22f46a50708e2514f41d92d04d9890a4 /recipes-devtools/python/python-prettytable_0.7.2.bb
parent1495520e6675316dcdb84dac6cd1276c612259b4 (diff)
downloadmeta-python2-82bae8d33d77d3d3c4a2ce6c27c1fbd8288d5bb1.tar.gz
python-prettytable: fix files permissions
Got this runtime error: IOError: [Errno 13] Permission denied: '/usr/lib/python2.7/site-packages/prettytable-0.7.2-py2.7.egg-info/PKG-INFO' After some investigation, it looks like the pypi package is the culprit as almost all the files in the tar.gz are set to 600 instead of 644. (From meta-openembedded commit: 1e322de8e68a50a14bb1d4be83912e1a437daf3a) Signed-off-by: Marc Ferland <ferlandm@amotus.ca> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-prettytable_0.7.2.bb')
-rw-r--r--recipes-devtools/python/python-prettytable_0.7.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-prettytable_0.7.2.bb b/recipes-devtools/python/python-prettytable_0.7.2.bb
index f63457e..6f4390e 100644
--- a/recipes-devtools/python/python-prettytable_0.7.2.bb
+++ b/recipes-devtools/python/python-prettytable_0.7.2.bb
@@ -15,7 +15,7 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit setuptools
do_install_append() {
- perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt"`
+ perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
for f in $perm_files; do
chmod 644 "${f}"
done