aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-prettytable_0.7.2.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-02-22 08:34:59 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:47:26 +0100
commit297adb79dce33034695f5def55eaa501c8e129cb (patch)
tree6d6d28efe62b4bd971800ef0b44245c781c82713 /recipes-devtools/python/python-prettytable_0.7.2.bb
parent815fd86ecf30128591d92e237bf414509ec721cb (diff)
downloadmeta-python2-297adb79dce33034695f5def55eaa501c8e129cb.tar.gz
python-prettytable: fix fetch issues in divergent pypi url pattern
(From meta-openembedded commit: 2855970c92fccbb837ca9888d94a779978845d31) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-prettytable_0.7.2.bb')
-rw-r--r--recipes-devtools/python/python-prettytable_0.7.2.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-prettytable_0.7.2.bb b/recipes-devtools/python/python-prettytable_0.7.2.bb
index 14edb03..c8f7b5f 100644
--- a/recipes-devtools/python/python-prettytable_0.7.2.bb
+++ b/recipes-devtools/python/python-prettytable_0.7.2.bb
@@ -6,8 +6,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282"
SRC_URI[md5sum] = "0c1361104caff8b09f220748f9d69899"
SRC_URI[sha256sum] = "a53da3b43d7a5c229b5e3ca2892ef982c46b7923b51e98f0db49956531211c4f"
-PYPI_PACKAGE_EXT = "zip"
-inherit pypi setuptools
+SRCNAME = "prettytable"
+
+SRC_URI = "https://pypi.python.org/packages/source/P/PrettyTable/${SRCNAME}-${PV}.zip"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
do_install_append() {
perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt"`