aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pip_19.3.1.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-10-23 14:25:35 +0800
committerKhem Raj <raj.khem@gmail.com>2019-10-24 01:01:44 -0700
commit4ac62b4725e7992df89326963cc1e284f5808adb (patch)
treef9962481720ed62a4f1338495033758906f46995 /recipes-devtools/python/python-pip_19.3.1.bb
parent09fe081ce8ef54043cac8624e23aca5b57b6197e (diff)
downloadmeta-python2-4ac62b4725e7992df89326963cc1e284f5808adb.tar.gz
python-pip: upgrade 19.3 -> 19.3.1
(From meta-openembedded commit: 5886d975722e900e16f049aa762e53d2eab44f72) Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pip_19.3.1.bb')
-rw-r--r--recipes-devtools/python/python-pip_19.3.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pip_19.3.1.bb b/recipes-devtools/python/python-pip_19.3.1.bb
new file mode 100644
index 0000000..2827a12
--- /dev/null
+++ b/recipes-devtools/python/python-pip_19.3.1.bb
@@ -0,0 +1,14 @@
+SUMMARY = "PIP is a tool for installing and managing Python packages"
+HOMEPAGE = "https://pip.pypa.io/"
+LICENSE = "MIT & LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e"
+
+SRC_URI[md5sum] = "1aaaf90fbafc50e7ba1e66ffceb00960"
+SRC_URI[sha256sum] = "21207d76c1031e517668898a6b46a9fb1501c7a4710ef5dfd6a40ad9e6757ea7"
+
+inherit pypi setuptools
+
+# Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works
+RDEPENDS_${PN}_class-target = "python-modules python-distribute python-misc"
+
+BBCLASSEXTEND = "native nativesdk"