aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pip_1.3.1.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 13:34:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-30 12:49:45 +0200
commitc1be511062e74b633f66792c08eb6d38f717cea2 (patch)
tree725b828c5b7e4a79f380ce0e97e28e5b0a048dec /recipes-devtools/python/python-pip_1.3.1.bb
parent964a5b60bcc6b19c58589cb45ec405aac3b120e5 (diff)
downloadmeta-python2-c1be511062e74b633f66792c08eb6d38f717cea2.tar.gz
meta-python: rename recipes-python to recipes-devtools
* match old structure from meta-oe (From meta-openembedded commit: d22f4ca2e3e421615b601002061690a8f97257c0) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pip_1.3.1.bb')
-rw-r--r--recipes-devtools/python/python-pip_1.3.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pip_1.3.1.bb b/recipes-devtools/python/python-pip_1.3.1.bb
new file mode 100644
index 0000000..d1a7c8b
--- /dev/null
+++ b/recipes-devtools/python/python-pip_1.3.1.bb
@@ -0,0 +1,14 @@
+SUMMARY = "PIP is a tool for installing and managing Python packages"
+LICENSE = "MIT & GPL"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cd00425a3465a0e4c81929b94241d3de"
+
+SRC_URI = "https://pypi.python.org/packages/source/p/pip/pip-${PV}.tar.gz"
+SRC_URI[md5sum] = "cbb27a191cebc58997c4da8513863153"
+SRC_URI[sha256sum] = "145eaa5d1ea1b062663da1f3a97780d7edea4c63c68a37c463b1deedf7bb4957"
+
+S = "${WORKDIR}/pip-${PV}"
+
+inherit setuptools
+
+# Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works
+RDEPENDS_${PN} = "python-modules"