aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-passlib_1.7.2.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-01-02 13:37:53 +0800
committerTim Orling <ticotimo@gmail.com>2020-01-20 12:22:51 -0800
commit4ccceaf0c28203023130605d309b3d08841c894d (patch)
tree6a9bff2603f6314e30e7117ebae8aa2ace5341c6 /recipes-devtools/python/python-passlib_1.7.2.bb
parent4c30f7b00cd11ba71d282b784271fba85e3433d1 (diff)
downloadmeta-python2-4ccceaf0c28203023130605d309b3d08841c894d.tar.gz
python-passlib: upgrade 1.7.1 -> 1.7.2
License-Update: Copyright year updated to 2019. (From meta-openembedded commit: 09d087ae6648cdae7e1a083cb9f8700730e8e049) Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-passlib_1.7.2.bb')
-rw-r--r--recipes-devtools/python/python-passlib_1.7.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-passlib_1.7.2.bb b/recipes-devtools/python/python-passlib_1.7.2.bb
new file mode 100644
index 0000000..e47d18f
--- /dev/null
+++ b/recipes-devtools/python/python-passlib_1.7.2.bb
@@ -0,0 +1,21 @@
+SUMMARY = "comprehensive password hashing framework supporting over 30 schemes"
+DESCRIPTION = "\
+Passlib is a password hashing library for Python 2 & 3, which provides cross-platform \
+implementations of over 30 password hashing algorithms, as well as a framework for \
+managing existing password hashes. It’s designed to be useful for a wide range of \
+tasks, from verifying a hash found in /etc/shadow, to providing full-strength password \
+hashing for multi-user applications."
+HOMEPAGE = "https://bitbucket.org/ecollins/passlib"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=44fd7dcd5d42b48d6dea59ac643a0179"
+
+SRC_URI[md5sum] = "b908529cfd4c33057c244324c692eae7"
+SRC_URI[sha256sum] = "8d666cef936198bc2ab47ee9b0410c94adf2ba798e5a84bf220be079ae7ab6a8"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-netclient \
+"