aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pamela_0.3.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-26 21:20:53 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:02:53 -0800
commite361b57cf3d9d6b871d1d165fe455b6ce6075dfb (patch)
tree70d441d87f65d333e22c4b2ecbefd1536e141ccb /recipes-devtools/python/python-pamela_0.3.0.bb
parent0eb37ac4435f3a5f6730a9312b731059ed7e8797 (diff)
downloadmeta-python2-e361b57cf3d9d6b871d1d165fe455b6ce6075dfb.tar.gz
recipes-devtools: merge inc and bb PART I
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop some dangling inc files and some python3 recipes. Enforce Debian naming (python-foo). Only recipes that are executable tools, such as 'gyp' or 'gateone' should be exceptions. When in doubt, search for what the package is named in Debian or Fedora. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pamela_0.3.0.bb')
-rw-r--r--recipes-devtools/python/python-pamela_0.3.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pamela_0.3.0.bb b/recipes-devtools/python/python-pamela_0.3.0.bb
new file mode 100644
index 0000000..7c39f28
--- /dev/null
+++ b/recipes-devtools/python/python-pamela_0.3.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Pamela: yet another Python wrapper for PAM"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bfb663f37eb99232bc8ccfa4ea8f1202"
+
+SRC_URI[md5sum] = "de6516118d51eb5fc97017f3b6d5c68b"
+SRC_URI[sha256sum] = "1e198446a6cdd87704aa0def7621d62e7c20b0e6068e2788b9a866a8355e5d6b"
+
+PYPI_PACKAGE = "pamela"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "libpam"
+
+inherit features_check
+REQUIRED_DISTRO_FEATURES = "pam"
+
+# meta-python recipe did not follow Debian naming
+PROVIDES += "pamela"