aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-numeric
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 13:34:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-30 12:49:45 +0200
commitc1be511062e74b633f66792c08eb6d38f717cea2 (patch)
tree725b828c5b7e4a79f380ce0e97e28e5b0a048dec /recipes-devtools/python/python-numeric
parent964a5b60bcc6b19c58589cb45ec405aac3b120e5 (diff)
downloadmeta-python2-c1be511062e74b633f66792c08eb6d38f717cea2.tar.gz
meta-python: rename recipes-python to recipes-devtools
* match old structure from meta-oe (From meta-openembedded commit: d22f4ca2e3e421615b601002061690a8f97257c0) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-numeric')
-rw-r--r--recipes-devtools/python/python-numeric/no-lapack.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-numeric/no-lapack.patch b/recipes-devtools/python/python-numeric/no-lapack.patch
new file mode 100644
index 0000000..c1916b8
--- /dev/null
+++ b/recipes-devtools/python/python-numeric/no-lapack.patch
@@ -0,0 +1,33 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- Numeric-23.7/setup.py~nolapack
++++ Numeric-23.7/setup.py
+@@ -32,7 +32,7 @@
+ mathlibs = []
+
+ # delete all but the first one in this list if using your own LAPACK/BLAS
+-sourcelist = [os.path.join('Src', 'lapack_litemodule.c'),
++sourcelist = [
+ #os.path.join('Src', 'blas_lite.c'),
+ #os.path.join('Src', 'f2c_lite.c'),
+ #os.path.join('Src', 'zlapack_lite.c'),
+@@ -40,12 +40,12 @@
+ ]
+ # set these to use your own BLAS;
+
+-library_dirs_list = ['/usr/lib/atlas']
+-libraries_list = ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
++library_dirs_list = []
++libraries_list = []
+
+ # set to true (1), if you also want BLAS optimized matrixmultiply/dot/innerproduct
+-use_dotblas = 1
+-include_dirs = ['/usr/include/atlas']
++use_dotblas = 0
++include_dirs = []
+ # You may need to set this to find cblas.h
+ # e.g. on UNIX using ATLAS this should be ['/usr/include/atlas']
+ extra_link_args = []