aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-27 21:32:09 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:04:08 -0800
commitcbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af (patch)
tree08959adf4d3ae8854cb39af6dab9851533659522 /recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb
parentda918f657c32ff9a5b5d9969604a2e255af473ec (diff)
downloadmeta-python2-cbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af.tar.gz
recipes-devtools: merge inc and bb PART V
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb')
-rw-r--r--recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb36
1 files changed, 35 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb b/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb
index 9cd881a..4795f30 100644
--- a/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb
+++ b/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb
@@ -1,6 +1,40 @@
-require python-ndg-httpsclient.inc
+
+SUMMARY = "Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
+DESCRIPTION = "A HTTPS client implementation for \
+\
+ httplib (Python 2), http.client (Python 3) and \
+ urllib2 (Python 2) and urllib (Python 3) \
+\
+… based on PyOpenSSL. PyOpenSSL provides a more fully featured SSL \
+implementation over the default provided with Python and importantly enables \
+full verification of the SSL peer using pyasn1."
+HOMEPAGE = "https://github.com/cedadev/ndg_httpsclient/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://MANIFEST.in;md5=ce22c0cd986d2de3f7073cd6b5523ae0"
+
+SRC_URI[md5sum] = "b0fc8ea38f87d2c1ab1ed79a95c078f9"
+SRC_URI[sha256sum] = "d72faed0376ab039736c2ba12e30695e2788c4aa569c9c3e3d72131de2592210"
+
+PYPI_PACKAGE = "ndg_httpsclient"
+
+DEPENDS += " \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-pyasn1 \
+"
+
inherit pypi setuptools update-alternatives
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-pyasn1 \
+"
+
+UPSTREAM_CHECK_REGEX = ""
+
ALTERNATIVE_${PN} = "ndg_httpclient"
ALTERNATIVE_LINK_NAME[ndg_httpclient] = "${bindir}/ndg_httpclient"
ALTERNATIVE_PRIORITY = "20"
+
+BBCLASSEXTEND = "native nativesdk"