aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-mccabe
diff options
context:
space:
mode:
authormingli.yu@windriver.com <mingli.yu@windriver.com>2016-07-29 17:00:08 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-05 12:16:38 +0200
commit62340ed96634c0da2f8b8daec1b40b4cda63eafd (patch)
tree7b8b6d7aad2cdff6698cbab0c46a468d12d913d5 /recipes-devtools/python/python-mccabe
parent2379899543cc1686ac71953b76ac3a21231de083 (diff)
downloadmeta-python2-62340ed96634c0da2f8b8daec1b40b4cda63eafd.tar.gz
python-mccabe: Remove unnecessary setup_requires pytest-runner
* Remove setup_requires pytest-runner as the setup_requires pytest-runner actually is not used for pytest which only in do_compile phase via setup.py build (From meta-openembedded commit: 7e4f22517ada29f634970721481f0a7de1f3bffd) Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-mccabe')
-rw-r--r--recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch b/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch
new file mode 100644
index 0000000..941bed3
--- /dev/null
+++ b/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch
@@ -0,0 +1,33 @@
+From 3484bdfa7adbaebcf8bb8e7d4820f64b12717932 Mon Sep 17 00:00:00 2001
+From: Mingli Yu <mingli.yu@windriver.com>
+Date: Fri, 29 Jul 2016 15:37:18 +0800
+Subject: [PATCH] python-mccabe: remove unnecessary setup_requires
+ pytest-runner
+
+* Remove setup_requires pytest-runner as the
+ setup_requires pytest-runner actually is not
+ used for pytest which only in do_compile phase
+ via setup.py build
+
+Upstream-Status: Pending
+
+Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+---
+ setup.py | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index e59903d..bf2aaba 100644
+--- a/setup.py
++++ b/setup.py
+@@ -33,7 +33,6 @@ setup(
+ license='Expat license',
+ py_modules=['mccabe'],
+ zip_safe=False,
+- setup_requires=['pytest-runner'],
+ tests_require=['pytest'],
+ entry_points={
+ 'flake8.extension': [
+--
+2.8.1
+