aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-matplotlib
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 13:34:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-30 12:49:45 +0200
commitc1be511062e74b633f66792c08eb6d38f717cea2 (patch)
tree725b828c5b7e4a79f380ce0e97e28e5b0a048dec /recipes-devtools/python/python-matplotlib
parent964a5b60bcc6b19c58589cb45ec405aac3b120e5 (diff)
downloadmeta-python2-c1be511062e74b633f66792c08eb6d38f717cea2.tar.gz
meta-python: rename recipes-python to recipes-devtools
* match old structure from meta-oe (From meta-openembedded commit: d22f4ca2e3e421615b601002061690a8f97257c0) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-matplotlib')
-rw-r--r--recipes-devtools/python/python-matplotlib/fix_setup.patch29
-rw-r--r--recipes-devtools/python/python-matplotlib/fix_setupext.patch29
2 files changed, 58 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-matplotlib/fix_setup.patch b/recipes-devtools/python/python-matplotlib/fix_setup.patch
new file mode 100644
index 0000000..9381583
--- /dev/null
+++ b/recipes-devtools/python/python-matplotlib/fix_setup.patch
@@ -0,0 +1,29 @@
+This fixes the dependency checks inside of setup.py since things like
+'import numpy' won't work with bitbake.
+
+diff --git a/setup.py b/setup.py
+index 2f13821..e6d6ed0 100644
+--- a/setup.py
++++ b/setup.py
+@@ -113,12 +113,6 @@ if 1:
+ baseline_images = [chop_package(f) for f in baseline_images]
+ package_data['matplotlib'].extend(baseline_images)
+
+-if not check_for_numpy():
+- sys.exit(1)
+-
+-if not check_for_freetype():
+- sys.exit(1)
+-
+ build_ft2font(ext_modules, packages)
+ build_ttconv(ext_modules, packages)
+ build_contour(ext_modules, packages)
+@@ -129,7 +123,7 @@ build_tri(ext_modules, packages)
+
+ print_raw("")
+ print_raw("OPTIONAL BACKEND DEPENDENCIES")
+-has_libpng = check_for_libpng()
++has_libpng = True
+
+ if has_libpng and options['build_agg']:
+ build_agg(ext_modules, packages)
diff --git a/recipes-devtools/python/python-matplotlib/fix_setupext.patch b/recipes-devtools/python/python-matplotlib/fix_setupext.patch
new file mode 100644
index 0000000..e071595
--- /dev/null
+++ b/recipes-devtools/python/python-matplotlib/fix_setupext.patch
@@ -0,0 +1,29 @@
+This fixes the numpy import problem in setupext.py using a hard-coded path.
+
+diff --git a/setupext.py b/setupext.py
+index 962cedc..82297c4 100644
+--- a/setupext.py
++++ b/setupext.py
+@@ -176,10 +176,7 @@ if os.path.exists(setup_cfg):
+ except: pass
+
+ # For get_base_flags:
+-if options['basedirlist']:
+- basedirlist = options['basedirlist'].split()
+-else:
+- basedirlist = basedir[sys.platform]
++basedirlist = [os.environ['STAGING_LIBDIR']]
+ print("basedirlist is: %s" % basedirlist)
+
+ if options['display_status']:
+@@ -555,8 +552,8 @@ def check_for_numpy():
+
+ def add_numpy_flags(module):
+ "Add the modules flags to build extensions which use numpy"
+- import numpy
+- module.include_dirs.append(numpy.get_include())
++ # Hard-coded path for OE since I know this is where numpy's include dir will be
++ module.include_dirs.append(os.path.join(os.environ['STAGING_LIBDIR'], 'python2.7/site-packages/numpy/core/include/'))
+
+ def add_png_flags(module):
+ try_pkgconfig(module, 'libpng', 'png')