aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-matplotlib/fix_setup.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-09-01 15:27:20 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-07 10:57:37 +0200
commitc7c3c274caa579428c561a3491341c5e2081252a (patch)
tree7a0b8606642d5c84a15d122048753f48455d6063 /recipes-devtools/python/python-matplotlib/fix_setup.patch
parent255afd38762f1f35945dae7c6938b3e86a14b050 (diff)
downloadmeta-python2-c7c3c274caa579428c561a3491341c5e2081252a.tar.gz
python-matplotlib: Upgrade to 2.0.2
(From meta-openembedded commit: 10c8c39c25d902ab5268fa48ac2bc0e42e65b179) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-matplotlib/fix_setup.patch')
-rw-r--r--recipes-devtools/python/python-matplotlib/fix_setup.patch29
1 files changed, 0 insertions, 29 deletions
diff --git a/recipes-devtools/python/python-matplotlib/fix_setup.patch b/recipes-devtools/python/python-matplotlib/fix_setup.patch
deleted file mode 100644
index 9381583..0000000
--- a/recipes-devtools/python/python-matplotlib/fix_setup.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-This fixes the dependency checks inside of setup.py since things like
-'import numpy' won't work with bitbake.
-
-diff --git a/setup.py b/setup.py
-index 2f13821..e6d6ed0 100644
---- a/setup.py
-+++ b/setup.py
-@@ -113,12 +113,6 @@ if 1:
- baseline_images = [chop_package(f) for f in baseline_images]
- package_data['matplotlib'].extend(baseline_images)
-
--if not check_for_numpy():
-- sys.exit(1)
--
--if not check_for_freetype():
-- sys.exit(1)
--
- build_ft2font(ext_modules, packages)
- build_ttconv(ext_modules, packages)
- build_contour(ext_modules, packages)
-@@ -129,7 +123,7 @@ build_tri(ext_modules, packages)
-
- print_raw("")
- print_raw("OPTIONAL BACKEND DEPENDENCIES")
--has_libpng = check_for_libpng()
-+has_libpng = True
-
- if has_libpng and options['build_agg']:
- build_agg(ext_modules, packages)