aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-m2crypto_0.30.1.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2020-01-18 20:13:59 -0800
committerTim Orling <ticotimo@gmail.com>2020-01-18 22:20:30 -0800
commit8d386367d6f36d23316c4d4ca2598fef14071ca9 (patch)
treea9da5f28341709ee7dd7c30a4fe5aa378a8496d5 /recipes-devtools/python/python-m2crypto_0.30.1.bb
parent65501feea58c75b6ca6ea454e0465e99266e08e4 (diff)
downloadmeta-python2-8d386367d6f36d23316c4d4ca2598fef14071ca9.tar.gz
python-m2crypto: add missing RDEPENDS
* Missing run-time dependencies: python-datetime python-distutils python-logging python-netserver python-smtpd python-typing python-xmlrpc Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-m2crypto_0.30.1.bb')
-rw-r--r--recipes-devtools/python/python-m2crypto_0.30.1.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-m2crypto_0.30.1.bb b/recipes-devtools/python/python-m2crypto_0.30.1.bb
index 22bf56a..968dd72 100644
--- a/recipes-devtools/python/python-m2crypto_0.30.1.bb
+++ b/recipes-devtools/python/python-m2crypto_0.30.1.bb
@@ -19,7 +19,15 @@ PYPI_PACKAGE = "M2Crypto"
inherit pypi siteinfo setuptools
-RDEPENDS_${PN} += "python-typing"
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-distutils \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-smtpd \
+ ${PYTHON_PN}-typing \
+ ${PYTHON_PN}-xmlrpc \
+ "
DISTUTILS_BUILD_ARGS += "build_ext --openssl=${STAGING_EXECPREFIXDIR} -I${STAGING_INCDIR}"
DISTUTILS_INSTALL_ARGS += "build_ext --openssl=${STAGING_EXECPREFIXDIR}"