aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-m2crypto
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2018-03-22 13:53:53 +0800
committerArmin Kuster <akuster808@gmail.com>2018-04-08 17:00:06 -0700
commite034b829c6843c1cfceab8e5aaefd6549224dc70 (patch)
treeef12302c5e801a2ed3459286db01327079aa64a3 /recipes-devtools/python/python-m2crypto
parent0d557a6d20db1de1cedcd5615c04371f9f95a881 (diff)
downloadmeta-python2-e034b829c6843c1cfceab8e5aaefd6549224dc70.tar.gz
python-m2crypto: refresh patch
Fix QA warning: WARNING: python-m2crypto-native-0.26.4-r0 do_patch: Some of the context lines in patches were ignored. This can lead to incorrectly applied patches. The context lines in the patches can be updated with devtool: devtool modify <recipe> devtool finish --force-patch-refresh <recipe> <layer_path> Then the updated patches and the source tree (in devtool's workspace) should be reviewed to make sure the patches apply in the correct place and don't introduce duplicate lines (which can, and does happen when some of the context is ignored). Further information: http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450 Details: Applying patch 0001-setup.py-link-in-sysroot-not-in-host-directories.patch patching file setup.py Hunk #1 succeeded at 127 with fuzz 1 (offset 65 lines). Hunk #2 succeeded at 143 (offset 68 lines). Now at patch 0001-setup.py-link-in-sysroot-not-in-host-directories.patch (From meta-openembedded commit: 0d9ca0ba17242b82861d68e06bde1ba1692fd842) Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-m2crypto')
-rw-r--r--recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch19
1 files changed, 11 insertions, 8 deletions
diff --git a/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
index 819c8e5..c71b16f 100644
--- a/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
+++ b/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
@@ -1,4 +1,4 @@
-From f11b9c71080513f9b867ba8f40613ba2ebc6e960 Mon Sep 17 00:00:00 2001
+From dfb83a41aaeae326e9b6f02b233af375bc7b8815 Mon Sep 17 00:00:00 2001
From: Koen Kooi <koen@dominion.thruhere.net>
Date: Fri, 29 Mar 2013 15:17:17 +0100
Subject: [PATCH] setup.py: link in sysroot, not in host directories
@@ -10,12 +10,12 @@ Upstream-status: Unknown
setup.py | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
-Index: M2Crypto-0.23.0/setup.py
-===================================================================
---- M2Crypto-0.23.0.orig/setup.py
-+++ M2Crypto-0.23.0/setup.py
-@@ -62,7 +62,7 @@ class _M2CryptoBuildExt(build_ext.build_
- self.openssl = 'c:\\pkg'
+diff --git a/setup.py b/setup.py
+index 3407c82..15ed7cd 100644
+--- a/setup.py
++++ b/setup.py
+@@ -127,7 +127,7 @@ class _M2CryptoBuildExt(build_ext.build_ext):
+ self.openssl = os.path.join(self.openssl, 'OpenSSL')
else:
self.libraries = ['ssl', 'crypto']
- self.openssl = '/usr'
@@ -23,7 +23,7 @@ Index: M2Crypto-0.23.0/setup.py
def finalize_options(self):
'''Overloaded build_ext implementation to append custom openssl
-@@ -75,8 +75,8 @@ class _M2CryptoBuildExt(build_ext.build_
+@@ -143,8 +143,8 @@ class _M2CryptoBuildExt(build_ext.build_ext):
if _openssl and os.path.isdir(_openssl):
self.openssl = _openssl
@@ -34,3 +34,6 @@ Index: M2Crypto-0.23.0/setup.py
if platform.system() == "Linux":
if _multiarch: # on Fedora/RHEL it is an empty string
+--
+2.7.4
+