aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-idna_2.8.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-27 21:32:09 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:04:08 -0800
commitcbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af (patch)
tree08959adf4d3ae8854cb39af6dab9851533659522 /recipes-devtools/python/python-idna_2.8.bb
parentda918f657c32ff9a5b5d9969604a2e255af473ec (diff)
downloadmeta-python2-cbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af.tar.gz
recipes-devtools: merge inc and bb PART V
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-idna_2.8.bb')
-rw-r--r--recipes-devtools/python/python-idna_2.8.bb20
1 files changed, 19 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-idna_2.8.bb b/recipes-devtools/python/python-idna_2.8.bb
index 2dcf72a..74ed8e3 100644
--- a/recipes-devtools/python/python-idna_2.8.bb
+++ b/recipes-devtools/python/python-idna_2.8.bb
@@ -1,2 +1,20 @@
+SUMMARY = "Internationalised Domain Names in Applications"
+HOMEPAGE = "https://github.com/kjd/idna"
+LICENSE = "BSD-3-Clause & Python-2.0 & Unicode"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=782775b32f96098512e283fb5d4546cd"
+
+SRC_URI[md5sum] = "2e9ae0b4a0b26d1747c6127cdb060bc1"
+SRC_URI[sha256sum] = "c357b3f628cf53ae2c4c05627ecc484553142ca23264e593d327bcde5e9c3407"
+
inherit pypi setuptools
-require python-idna.inc
+
+RDEPENDS_${PN}_class-target = "\
+ ${PYTHON_PN}-codecs \
+"
+
+# Remove bundled egg-info
+do_compile_prepend() {
+ rm -rf ${S}/idna.egg-info
+}
+
+BBCLASSEXTEND = "native nativesdk"