aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-hypothesis_4.50.2.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-30 19:59:45 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 18:08:12 -0800
commitb0741dc775a904f82eac1ef80efef80437f677e2 (patch)
treebd113d8dc0f09c4989c4a968a9277fd010681740 /recipes-devtools/python/python-hypothesis_4.50.2.bb
parentf3505a453fa61faa01ff29293892315d9e1428a1 (diff)
downloadmeta-python2-b0741dc775a904f82eac1ef80efef80437f677e2.tar.gz
python-hypothesis: add recipe for 4.50.2
ptest dependency for python-cryptography Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-hypothesis_4.50.2.bb')
-rw-r--r--recipes-devtools/python/python-hypothesis_4.50.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-hypothesis_4.50.2.bb b/recipes-devtools/python/python-hypothesis_4.50.2.bb
new file mode 100644
index 0000000..4cf7d5d
--- /dev/null
+++ b/recipes-devtools/python/python-hypothesis_4.50.2.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A library for property based testing"
+DESCRIPTION = "Hypothesis is an advanced testing library for Python. It lets \
+you write tests which are parametrized by a source of examples, and then \
+generates simple and comprehensible examples that make your tests fail. This \
+lets you find more bugs in your code with less work."
+HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
+BUGTRACKER = "https://github.com/HypothesisWorks/hypothesis/issues"
+SECTION = "devel/python"
+
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
+
+SRC_URI[md5sum] = "2cf187bc0b3a61d08b13743985a71646"
+SRC_URI[sha256sum] = "c50157747f80930c0e9367a2ef10599204cc098007e18ba8daeac0620ee674cb"
+
+DEPENDS = "${PYTHON_PN}-attrs"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-enum34 \
+ "