aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-html5lib_1.0.1.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-27 21:32:09 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:04:08 -0800
commitcbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af (patch)
tree08959adf4d3ae8854cb39af6dab9851533659522 /recipes-devtools/python/python-html5lib_1.0.1.bb
parentda918f657c32ff9a5b5d9969604a2e255af473ec (diff)
downloadmeta-python2-cbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af.tar.gz
recipes-devtools: merge inc and bb PART V
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-html5lib_1.0.1.bb')
-rw-r--r--recipes-devtools/python/python-html5lib_1.0.1.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-html5lib_1.0.1.bb b/recipes-devtools/python/python-html5lib_1.0.1.bb
index f5941a2..21b80f2 100644
--- a/recipes-devtools/python/python-html5lib_1.0.1.bb
+++ b/recipes-devtools/python/python-html5lib_1.0.1.bb
@@ -1,2 +1,17 @@
-inherit setuptools
-require python-html5lib.inc
+SUMMARY = "HTML parser based on the WHATWG HTML specifcation"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1ba5ada9e6fead1fdc32f43c9f10ba7c"
+
+SRC_URI[md5sum] = "942a0688d6bdf20d087c9805c40182ad"
+SRC_URI[sha256sum] = "66cb0dcfdbbc4f9c3ba1a63fdb511ffdbd4f513b2b6d81b80cd26ce6b3fb3736"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-lxml \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-webencodings \
+ ${PYTHON_PN}-xml \
+"
+
+BBCLASSEXTEND = "native nativesdk"