aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-flask-restful_0.3.7.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-29 16:30:46 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:04:25 -0800
commit3a336d8f08b3f597807d3158077d0e1c830c75ed (patch)
tree133756c00c77a7d2062a29e7309970193d7cfde2 /recipes-devtools/python/python-flask-restful_0.3.7.bb
parentcbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af (diff)
downloadmeta-python2-3a336d8f08b3f597807d3158077d0e1c830c75ed.tar.gz
recipes-devtools: merge inc and bb PART VI
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-flask-restful_0.3.7.bb')
-rw-r--r--recipes-devtools/python/python-flask-restful_0.3.7.bb18
1 files changed, 16 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-flask-restful_0.3.7.bb b/recipes-devtools/python/python-flask-restful_0.3.7.bb
index 1968d1d..6138e8a 100644
--- a/recipes-devtools/python/python-flask-restful_0.3.7.bb
+++ b/recipes-devtools/python/python-flask-restful_0.3.7.bb
@@ -1,2 +1,16 @@
-inherit setuptools
-require python-flask-restful.inc
+SUMMARY = "Simple framework for creating REST APIs"
+DESCRIPTION = "\
+Flask-RESTful is an extension for Flask that adds support for quickly building \
+REST APIs"
+HOMEPAGE = "https://github.com/flask-restful/flask-restful"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=685bb55ed99a366bb431995f5eef2783"
+
+SRC_URI[md5sum] = "a7217ef1159be38af5faf61aa09aabef"
+SRC_URI[sha256sum] = "f8240ec12349afe8df1db168ea7c336c4e5b0271a36982bff7394f93275f2ca9"
+
+inherit pypi setuptools
+
+PYPI_PACKAGE = "Flask-RESTful"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-flask"