aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-flask-nav_0.6.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-29 16:30:46 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:04:25 -0800
commit3a336d8f08b3f597807d3158077d0e1c830c75ed (patch)
tree133756c00c77a7d2062a29e7309970193d7cfde2 /recipes-devtools/python/python-flask-nav_0.6.bb
parentcbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af (diff)
downloadmeta-python2-3a336d8f08b3f597807d3158077d0e1c830c75ed.tar.gz
recipes-devtools: merge inc and bb PART VI
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-flask-nav_0.6.bb')
-rw-r--r--recipes-devtools/python/python-flask-nav_0.6.bb20
1 files changed, 19 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-flask-nav_0.6.bb b/recipes-devtools/python/python-flask-nav_0.6.bb
index 30b5b3b..ce9047d 100644
--- a/recipes-devtools/python/python-flask-nav_0.6.bb
+++ b/recipes-devtools/python/python-flask-nav_0.6.bb
@@ -1,2 +1,20 @@
+SUMMARY = "Easily create navigation for Flask applications."
+DESCRIPTION = "Flask-Nav is a Flask-Extension to ease the creation of \
+navigational Elements in Applications. It provides means to Express the \
+Navigational structure and different ways to render these, making it easy to \
+custom tailor it for your application."
+HOMEPAGE = "https://github.com/mbr/flask-nav"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=2729ee82259d601d90d28b0574d12416"
+
+SRC_URI[md5sum] = "4d51cfd06d58f8d0fe85775a6696c0e5"
+SRC_URI[sha256sum] = "44e40b755380a1e68ab521a2f9174de259a2c94ddcdaabf36b3aca2e110a33f4"
+
+PYPI_PACKAGE = "flask-nav"
+
inherit pypi setuptools
-require python-flask-nav.inc
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-blinker \
+ ${PYTHON_PN}-flask \
+ "