aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-engineio_3.11.2.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-01-15 05:12:26 -0800
committerTim Orling <ticotimo@gmail.com>2020-01-24 00:17:44 -0800
commit32dd8abf72227569cecc40d7868ea79c19972236 (patch)
tree53221ef5b9c86b670002cefeac19a9e76253c31c /recipes-devtools/python/python-engineio_3.11.2.bb
parentc733e09ac63161b3d2241895a99a34afe5328603 (diff)
downloadmeta-python2-32dd8abf72227569cecc40d7868ea79c19972236.tar.gz
python-engineio: upgrade 3.11.1 -> 3.11.2
(From meta-openembedded commit: 947ad1caf125109121de52cce147d38cc1d01c30) Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-engineio_3.11.2.bb')
-rw-r--r--recipes-devtools/python/python-engineio_3.11.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-engineio_3.11.2.bb b/recipes-devtools/python/python-engineio_3.11.2.bb
new file mode 100644
index 0000000..09188b4
--- /dev/null
+++ b/recipes-devtools/python/python-engineio_3.11.2.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Engine.IO server"
+DESCRIPTION = "Python implementation of the Engine.IO realtime client and server."
+HOMEPAGE = "https://github.com/miguelgrinberg/python-engineio/"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=42d0a9e728978f0eeb759c3be91536b8"
+
+SRC_URI[md5sum] = "13345452be25c3b63d041f8f89e662d1"
+SRC_URI[sha256sum] = "47ae4a9b3b4f2e8a68929f37a518338838e119f24c9a9121af92c49f8bea55c3"
+
+PYPI_PACKAGE = "python-engineio"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN}_append_class-target = "\
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-six \
+"