aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-daemon_2.1.2.bb
diff options
context:
space:
mode:
authorKrzysztof Kozlowski <krzk@kernel.org>2017-07-09 17:47:22 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:44:32 +0200
commit6598126167c16668ce05377b622c9821cb61ef2d (patch)
tree5c4897e27d028bc8ce5c680ec60de890c551b17c /recipes-devtools/python/python-daemon_2.1.2.bb
parent19b92f323a630379a660fa1938f8f9a40f9801c7 (diff)
downloadmeta-python2-6598126167c16668ce05377b622c9821cb61ef2d.tar.gz
meta-python: Add python-daemon recipe and its dependencies
Add recipes for python-daemon PIP package with its dependencies - lockfile and docutils. (From meta-openembedded commit: 5dcaa1231be0a2d6ded44855f8b5b054cb04c6f3) Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-daemon_2.1.2.bb')
-rw-r--r--recipes-devtools/python/python-daemon_2.1.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-daemon_2.1.2.bb b/recipes-devtools/python/python-daemon_2.1.2.bb
new file mode 100644
index 0000000..4c18e2b
--- /dev/null
+++ b/recipes-devtools/python/python-daemon_2.1.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Library to implement a well-behaved Unix daemon process"
+HOMEPAGE = "https://pagure.io/python-daemon/"
+SECTION = "devel/python"
+
+DEPENDS = "python-docutils"
+RDEPENDS_${PN} = "python-docutils \
+ python-lockfile (>= 0.10) \
+ python-resource \
+"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit pypi setuptools
+
+SRC_URI[md5sum] = "9c57343d81f2a96c51cffeab982b04d2"
+SRC_URI[sha256sum] = "261c859be5c12ae7d4286dc6951e87e9e1a70a882a8b41fd926efc1ec4214f73"
+
+# Fix for build error in Yocto:
+# i = p.rfind('/') + 1
+# AttributeError: 'NoneType' object has no attribute 'rfind'
+#S = "${WORKDIR}/python-daemon"
+SRC_URI_append = " \
+ file://0001-Workaround-for-issue-2-1.patch \
+"
+
+PYPI_PACKAGE = "python-daemon"