aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-cryptography-vectors_2.8.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-29 16:30:46 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:04:25 -0800
commit3a336d8f08b3f597807d3158077d0e1c830c75ed (patch)
tree133756c00c77a7d2062a29e7309970193d7cfde2 /recipes-devtools/python/python-cryptography-vectors_2.8.bb
parentcbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af (diff)
downloadmeta-python2-3a336d8f08b3f597807d3158077d0e1c830c75ed.tar.gz
recipes-devtools: merge inc and bb PART VI
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-cryptography-vectors_2.8.bb')
-rw-r--r--recipes-devtools/python/python-cryptography-vectors_2.8.bb25
1 files changed, 24 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-cryptography-vectors_2.8.bb b/recipes-devtools/python/python-cryptography-vectors_2.8.bb
index 4975278..a7c36e2 100644
--- a/recipes-devtools/python/python-cryptography-vectors_2.8.bb
+++ b/recipes-devtools/python/python-cryptography-vectors_2.8.bb
@@ -1,2 +1,25 @@
+SUMMARY = "Test vectors for the cryptography package."
+DESCRIPTION = "cryptography is a package which provides cryptographic recipes \
+and primitives to Python developers. Our goal is for it to be your 'cryptographic \
+standard library'."
+HOMEPAGE = "https://cryptography.io/"
+SECTION = "devel/python"
+
+LICENSE = "Apache-2.0 | BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
+
+SRC_URI[md5sum] = "a744ed29bb9ef56b3a50317fea3b218e"
+SRC_URI[sha256sum] = "6cd32174c56a3eca72f64af43c1daacaae758cfa5ff9d280dfcf818fa11ef116"
+
+DEPENDS += " \
+ ${PYTHON_PN}-cryptography \
+"
+
+
+PYPI_PACKAGE = "cryptography_vectors"
+
+UPSTREAM_CHECK_REGEX = ""
+
inherit pypi setuptools
-require python-cryptography-vectors.inc
+
+BBCLASSEXTEND = "native nativesdk"