aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-crcmod_1.7.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-29 16:30:46 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:04:25 -0800
commit3a336d8f08b3f597807d3158077d0e1c830c75ed (patch)
tree133756c00c77a7d2062a29e7309970193d7cfde2 /recipes-devtools/python/python-crcmod_1.7.bb
parentcbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af (diff)
downloadmeta-python2-3a336d8f08b3f597807d3158077d0e1c830c75ed.tar.gz
recipes-devtools: merge inc and bb PART VI
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-crcmod_1.7.bb')
-rw-r--r--recipes-devtools/python/python-crcmod_1.7.bb23
1 files changed, 21 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-crcmod_1.7.bb b/recipes-devtools/python/python-crcmod_1.7.bb
index 45b9a2c..b15bb2d 100644
--- a/recipes-devtools/python/python-crcmod_1.7.bb
+++ b/recipes-devtools/python/python-crcmod_1.7.bb
@@ -1,2 +1,21 @@
-inherit setuptools
-require python-crcmod.inc
+SUMMARY = "A Python module for generating objects that compute the Cyclic Redundancy Check."
+DESCRIPTION = "The software in this package is a Python module for generating \
+objects that compute the Cyclic Redundancy Check (CRC). There is no attempt in \
+this package to explain how the CRC works. There are a number of resources on \
+the web that give a good explanation of the algorithms. Just do a Google search \
+for 'crc calculation' and browse till you find what you need. Another resource \
+can be found in chapter 20 of the book 'Numerical Recipes in C' by Press et. al"
+HOMEPAGE = "https://pypi.org/project/crcmod"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a19291627cad2d1dfbfcf3c9fb85c2"
+
+SRC_URI[md5sum] = "2d5b92117d958dcead94f9e17f54cd32"
+SRC_URI[sha256sum] = "dc7051a0db5f2bd48665a990d3ec1cc305a466a77358ca4492826f41f283601e"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "${PYTHON_PN}-unittest"
+
+BBCLASSEXTEND = "native nativesdk"