aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-chardet_3.0.4.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-06-23 10:30:29 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-06-23 11:14:33 +0200
commit8db9e4f6ceae33d7a4f55453d31e69f9858af4eb (patch)
tree540d84b7e559e31fae58638a3dbd425428a8bffe /recipes-devtools/python/python-chardet_3.0.4.bb
parent810d6d842f103eb59f18b06426106462b15de7e2 (diff)
downloadmeta-python2-hardknott-next.tar.gz
python-chardet: rename ${bindir}/chardetect to avoid conflict with python3-chardethardknott-nexthardknott
* to allow both python-chardet and python3-chardet to be installed in the same image * now it fails with: Collected errors: * check_data_file_clashes: Package python-chardet wants to install file image/1.0/rootfs/usr/bin/chardetect But that file is already provided by package * python3-chardet * the only difference is the shebang: --- python-chardet/3.0.4-r0/image/usr/bin/chardetect 2021-06-23 01:24:17.172638046 -0700 +++ python3-chardet/3.0.4-r0/image/usr/bin/chardetect 2021-06-23 01:24:17.412641733 -0700 @@ -1,4 +1,4 @@ -#!/usr/bin/env python +#!/usr/bin/env python3 # EASY-INSTALL-ENTRY-SCRIPT: 'chardet==3.0.4','console_scripts','chardetect' __requires__ = 'chardet==3.0.4' import re Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-chardet_3.0.4.bb')
-rw-r--r--recipes-devtools/python/python-chardet_3.0.4.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-chardet_3.0.4.bb b/recipes-devtools/python/python-chardet_3.0.4.bb
index 6b8e560..ea02f4e 100644
--- a/recipes-devtools/python/python-chardet_3.0.4.bb
+++ b/recipes-devtools/python/python-chardet_3.0.4.bb
@@ -26,6 +26,10 @@ RDEPENDS_${PN}_class-target += " \
inherit pypi setuptools
+do_install_append() {
+ mv ${D}${bindir}/chardetect ${D}${bindir}/chardetect-py2
+}
+
RDEPENDS_${PN} += "${PYTHON_PN}-argparse"
BBCLASSEXTEND = "native nativesdk"