aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-backports-ssl_3.7.0.1.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-30 14:50:31 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 18:08:12 -0800
commita54c8165dbf75e8db0aa130668c90e5401d47354 (patch)
treea0b4479ffd670cc548d0ad2fc22de805f08750fc /recipes-devtools/python/python-backports-ssl_3.7.0.1.bb
parent18615f47dbbd109bc2350b86e078da93d066e5e5 (diff)
downloadmeta-python2-a54c8165dbf75e8db0aa130668c90e5401d47354.tar.gz
python-backports-init: Add helper class and recipe
Recipes that install in the backports namespace have a tendency to conflict in the installation of .../site-packages/backports/__init__.py Add a class and recipe to help avoid the conflict. Modify recipes that are affected: - python-backports-functools-lru-cache - python-backports-ssl - python-configparser Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-backports-ssl_3.7.0.1.bb')
-rw-r--r--recipes-devtools/python/python-backports-ssl_3.7.0.1.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-backports-ssl_3.7.0.1.bb b/recipes-devtools/python/python-backports-ssl_3.7.0.1.bb
index 9032a7c..126d0ee 100644
--- a/recipes-devtools/python/python-backports-ssl_3.7.0.1.bb
+++ b/recipes-devtools/python/python-backports-ssl_3.7.0.1.bb
@@ -13,6 +13,7 @@ SRC_URI[md5sum] = "32d2f593af01a046bec3d2f5181a420a"
SRC_URI[sha256sum] = "bb82e60f9fbf4c080eabd957c39f0641f0fc247d9a16e31e26d594d8f42b9fd2"
PYPI_PACKAGE = "backports.ssl_match_hostname"
-inherit pypi setuptools
+
+inherit pypi setuptools python-backports-init
RDEPENDS_${PN} += "${PYTHON_PN}-pkgutil"