aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-30 14:50:31 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 18:08:12 -0800
commita54c8165dbf75e8db0aa130668c90e5401d47354 (patch)
treea0b4479ffd670cc548d0ad2fc22de805f08750fc /recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb
parent18615f47dbbd109bc2350b86e078da93d066e5e5 (diff)
downloadmeta-python2-a54c8165dbf75e8db0aa130668c90e5401d47354.tar.gz
python-backports-init: Add helper class and recipe
Recipes that install in the backports namespace have a tendency to conflict in the installation of .../site-packages/backports/__init__.py Add a class and recipe to help avoid the conflict. Modify recipes that are affected: - python-backports-functools-lru-cache - python-backports-ssl - python-configparser Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb')
-rw-r--r--recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb b/recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb
index 825444f..11c1533 100644
--- a/recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb
+++ b/recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb
@@ -11,7 +11,7 @@ SRC_URI[sha256sum] = "9d98697f088eb1b0fa451391f91afb5e3ebde16bbdb272819fd091151f
DEPENDS += "python-setuptools-scm-native"
-inherit setuptools pypi
+inherit setuptools pypi python-backports-init
RDEPENDS_${PN} += "\
${PYTHON_PN}-pickle \