aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-automat.inc
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-26 09:19:11 -0500
committerArmin Kuster <akuster808@gmail.com>2018-03-12 14:43:28 -0700
commit63ba344ff4aed8b04650aff90060c60ec371c78c (patch)
tree50ec333fd7a31237d0729ed8ca642c2ef6b53683 /recipes-devtools/python/python-automat.inc
parent98111ec7351403a097463a1798cc780a5eb3efc8 (diff)
downloadmeta-python2-63ba344ff4aed8b04650aff90060c60ec371c78c.tar.gz
python-automat: fix build dependencies to avoid download during do_compile
Add the correct version of python{3}-setuptools-scm-native Remove the dependency on m2r (From meta-openembedded commit: dacfa2b1920e285531bec55cd2f08743390aaf57) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-automat.inc')
-rw-r--r--recipes-devtools/python/python-automat.inc8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-automat.inc b/recipes-devtools/python/python-automat.inc
index 1ac5d3b..43b9ce9 100644
--- a/recipes-devtools/python/python-automat.inc
+++ b/recipes-devtools/python/python-automat.inc
@@ -3,6 +3,8 @@ HOMEPAGE = "https://github.com/glyph/Automat"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4ad213bcca81688e94593e5f60c87477"
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-automat:"
+
SRC_URI[md5sum] = "ad7bba58d262d8956d732330cb5ef53d"
SRC_URI[sha256sum] = "3c1fd04ecf08ac87b4dd3feae409542e9bf7827257097b2b6ed5692f69d6f6a8"
@@ -10,6 +12,12 @@ PYPI_PACKAGE = "Automat"
inherit pypi
+SRC_URI_append = " \
+ file://0001-setup.py-remove-the-dependency-on-m2r.patch \
+"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
RDEPENDS_${PN} += "\
${PYTHON_PN}-attrs \
${PYTHON_PN}-six \