aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/gyp
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2019-11-10 21:28:03 +0000
committerKhem Raj <raj.khem@gmail.com>2019-11-11 21:21:13 -0800
commitaa94f62cb85623acca601292de5ee66719e7ebe3 (patch)
treecb20e8c8d89a970747b4ed26bec33ad59be8dc5f /recipes-devtools/gyp
parent92133bac05aefac86997fa86e013782b85ada8a6 (diff)
downloadmeta-python2-aa94f62cb85623acca601292de5ee66719e7ebe3.tar.gz
gyp: provide a python2 version of gyp as gyp-py2
Doing so will allow us to change the NodeJS build to use the system gyp, rather than its own copy. NodeJS still uses python2, and imports parts of gyp directly. Also note that Debian only provides a python2 version. (From meta-openembedded commit: b877b1938121b4f196133079d52131e669f4e15b) Signed-off-by: André Draszik <git@andred.net> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/gyp')
-rw-r--r--recipes-devtools/gyp/gyp-py2_git.bb2
-rw-r--r--recipes-devtools/gyp/gyp.inc13
-rw-r--r--recipes-devtools/gyp/gyp_git.bb15
3 files changed, 16 insertions, 14 deletions
diff --git a/recipes-devtools/gyp/gyp-py2_git.bb b/recipes-devtools/gyp/gyp-py2_git.bb
new file mode 100644
index 0000000..d69b92c
--- /dev/null
+++ b/recipes-devtools/gyp/gyp-py2_git.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require gyp.inc
diff --git a/recipes-devtools/gyp/gyp.inc b/recipes-devtools/gyp/gyp.inc
new file mode 100644
index 0000000..98ed42c
--- /dev/null
+++ b/recipes-devtools/gyp/gyp.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems."
+HOMEPAGE = "https://gyp.gsrc.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
+SECTION = "devel"
+
+SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https"
+SRCREV = "fcd686f1880fa52a1ee78d3e98af1b88cb334528"
+
+S = "${WORKDIR}/git"
+PV = "0.1+git${SRCPV}"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/gyp/gyp_git.bb b/recipes-devtools/gyp/gyp_git.bb
index 61f3c86..8e48a27 100644
--- a/recipes-devtools/gyp/gyp_git.bb
+++ b/recipes-devtools/gyp/gyp_git.bb
@@ -1,15 +1,2 @@
-DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems."
-HOMEPAGE = "https://gyp.gsrc.io/"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
-SECTION = "devel"
-
-SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https"
-SRCREV = "fcd686f1880fa52a1ee78d3e98af1b88cb334528"
-
-S = "${WORKDIR}/git"
-PV = "0.1+git${SRCPV}"
-
inherit setuptools3
-
-BBCLASSEXTEND = "native nativesdk"
+require gyp.inc