aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-12-01 16:52:47 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 16:52:47 -0800
commit836d0bcfabe44383501443e987c8a3a31b605ac5 (patch)
tree63a529823ee0939ab51b6f5c7430fbd54fcf0fde /recipes-core
parent19871c1d32aa6cb8bd617b6bb628f54a6da9ad2d (diff)
downloadmeta-python2-836d0bcfabe44383501443e987c8a3a31b605ac5.tar.gz
images/packagegroups: python2 only
Rename images and packagegroups so that they will not interfere with the similar recipes in meta-python. Drop all python3 references, this layer is python2 only. Fix ptest packagegroup, RDEPENDS on *-ptest. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/meta-python-image.bb6
-rw-r--r--recipes-core/images/meta-python2-image-base.bb (renamed from recipes-core/images/meta-python-image-base.bb)0
-rw-r--r--recipes-core/images/meta-python2-image.bb5
-rw-r--r--recipes-core/images/meta-python2-ptest-image.bb (renamed from recipes-core/images/meta-python-ptest-image.bb)0
-rw-r--r--recipes-core/packagegroups/packagegroup-meta-python2.bb (renamed from recipes-core/packagegroups/packagegroup-meta-python.bb)69
5 files changed, 7 insertions, 73 deletions
diff --git a/recipes-core/images/meta-python-image.bb b/recipes-core/images/meta-python-image.bb
deleted file mode 100644
index b082423..0000000
--- a/recipes-core/images/meta-python-image.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-require meta-python2-image-base.bb
-
-SUMMARY = "meta-python2 build test image"
-
-IMAGE_INSTALL += "packagegroup-meta-python2 \
- packagegroup-meta-python3"
diff --git a/recipes-core/images/meta-python-image-base.bb b/recipes-core/images/meta-python2-image-base.bb
index 6b43def..6b43def 100644
--- a/recipes-core/images/meta-python-image-base.bb
+++ b/recipes-core/images/meta-python2-image-base.bb
diff --git a/recipes-core/images/meta-python2-image.bb b/recipes-core/images/meta-python2-image.bb
new file mode 100644
index 0000000..9fe75ea
--- /dev/null
+++ b/recipes-core/images/meta-python2-image.bb
@@ -0,0 +1,5 @@
+require meta-python2-image-base.bb
+
+SUMMARY = "meta-python2 build test image"
+
+IMAGE_INSTALL += "packagegroup-meta-python2"
diff --git a/recipes-core/images/meta-python-ptest-image.bb b/recipes-core/images/meta-python2-ptest-image.bb
index ddf5664..ddf5664 100644
--- a/recipes-core/images/meta-python-ptest-image.bb
+++ b/recipes-core/images/meta-python2-ptest-image.bb
diff --git a/recipes-core/packagegroups/packagegroup-meta-python.bb b/recipes-core/packagegroups/packagegroup-meta-python2.bb
index 361fe9a..ebf20c9 100644
--- a/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/recipes-core/packagegroups/packagegroup-meta-python2.bb
@@ -5,7 +5,6 @@ inherit packagegroup
PROVIDES = "${PACKAGES}"
PACKAGES = ' \
packagegroup-meta-python2 \
- packagegroup-meta-python3 \
'
RDEPENDS_packagegroup-meta-python2 = "\
@@ -13,11 +12,6 @@ RDEPENDS_packagegroup-meta-python2 = "\
packagegroup-meta-python2-connectivity \
"
-RDEPENDS_packagegroup-meta-python3 = "\
- packagegroup-meta-python3-extended \
- packagegroup-meta-python3-connectivity \
-"
-
RDEPENDS_packagegroup-meta-python2 = "\
python-psutil python-certifi python-flask python-pyroute2 python-pyopenssl python-pylint \
python-semver python-wrapt python-networkx python-behave python-dominate python-flask-user \
@@ -66,45 +60,6 @@ RDEPENDS_packagegroup-meta-python2 = "\
${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python-systemd", "", d)} \
"
-RDEPENDS_packagegroup-meta-python3 = "\
- python3-pyserial python3-gevent python3-alembic python3-robotframework-seriallibrary \
- python3-rfc3987 python3-xlrd python3-bandit python3-constantly python3-inflection \
- python3-javaobj-py3 python3-sh python3-pycrypto python3-pyasn1 python3-pydbus python3-wtforms \
- python3-pybluez python3-babel python3-parse-type python3-bitarray python3-django-south \
- python3-pyusb python3-prctl python3-jinja2 python3-werkzeug python3-pyjks python3-requests-ftp \
- python3-behave python3-pyparsing python3-pyyaml python3-tzlocal python3-pretend python3-stevedore \
- python3-sijax python3-langtable python3-requests-file python3-crcmod python3-robotframework \
- python3-pint python3-coverage python3-iso8601 python3-ndg-httpsclient python3-yappi python3-twofish \
- python3-speaklater python3-smbus python3-djangorestframework python3-msgpack python3-jsonpointer \
- python3-flask-script python3-cassandra-driver python3-cython python3-ujson python3-aws-iot-device-sdk-python \
- python3-pytest-runner python3-pyiface python3-docutils python3-flask-login python3-markupsafe python3-setuptools-scm \
- python3-semver python3-sdnotify python3-flask-user python3-tornado python3-jsonpatch python3-pexpect \
- python3-progress python3-jsonschema python3-xstatic python3-pyroute2 python3-idna python3-sqlalchemy \
- python3-urllib3 python3-flask-mail python3-asn1crypto python3-pyinotify python3-intervals python3-pyperclip \
- python3-flask-bootstrap python3-pyudev python3-decorator python3-pybind11 python3-pluggy python3-redis \
- python3-pycryptodome python3-passlib python3-dominate python3-ply python3-ntplib python3-serpent python3-wrapt \
- python3-attrs python3-appdirs python3-isort python3-evdev python3-incremental python3-click python3-flask-nav \
- python3-webcolors python3-dateutil python3-blinker python3-hyperlink python3-lxml python3-pylint \
- python3-flask-migrate python3-pytest-tempdir python3-flask-restful python3-feedformatter \
- python3-pyasn1-modules python3-scapy python3-html5lib python3-dnspython python3-automat \
- python3-itsdangerous python3-pandas python3-pyfirmata python3-protobuf \
- python3-flask-babel python3-anyjson python3-flask-xstatic python3-multidict python3-prompt-toolkit \
- python3-periphery python3-greenlet python3-pytz python3-pyexpect python3-zopeinterface \
- python3-bcrypt python3-xstatic-font-awesome python3-m2crypto python3-parse python3-attr \
- python3-beautifulsoup4 python3-pycodestyle python3-oauthlib python3-grpcio python3-scrypt \
- python3-pyjwt python3-astroid python3-flask-pymongo python3-wcwidth python3-lazy-object-proxy \
- python3-websockets python3-pyzmq python3-pytest python3-chardet python3-vcversioner python3-whoosh \
- python3-pymisp python3-certifi python3-psutil python3-flask-sqlalchemy python3-humanize \
- python3-grpcio-tools python3-configparser python3-strict-rfc3339 python3-paho-mqtt \
- python3-pytest-helpers-namespace python3-flask python3-flask-wtf python3-visitor python3-pynetlinux \
- python3-requests python3-cryptography-vectors python3-spidev python3-pid python3-pymongo \
- python3-future python3-django python3-unidiff python3-webencodings python3-can python3-pyalsaaudio \
- python3-flask-sijax python3-cryptography python3-twisted python3-netaddr python3-pycparser \
- python3-flask-uploads python3-pysocks python3-cffi python3-editor python3-ptyprocess \
- python3-pyopenssl python3-ordered-set python3-simplejson python3-py \
- ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python3-systemd", "", d)} \
-"
-
RDEPENDS_packagegroup-meta-python2-extended = "\
python-pyephem \
python-cson \
@@ -112,15 +67,6 @@ RDEPENDS_packagegroup-meta-python2-extended = "\
python-pyparted \
"
-RDEPENDS_packagegroup-meta-python3-extended = "\
- python3-pykickstart \
- python3-meh \
- python3-blivet \
- python3-pywbem \
- python3-pyparted \
- ${@bb.utils.contains("DISTRO_FEATURES", "x11", "python3-blivetgui", "", d)} \
-"
-
RDEPENDS_packagegroup-meta-python2-connectivity = "\
python-pyro4 \
python-pytun \
@@ -131,20 +77,9 @@ RDEPENDS_packagegroup-meta-python2-connectivity = "\
python-gsocketpool \
"
-RDEPENDS_packagegroup-meta-python3-connectivity = "\
- python3-pytun \
- python3-mprpc \
- python3-pyconnman \
- python3-gsocketpool \
-"
-
RDEPENDS_packagegroup-meta-python2-ptest = "\
- python-pygpgme \
- python-cryptography \
- "
-
-RDEPENDS_packagegroup-meta-python3-ptest = "\
- python3-cryptography \
+ python-pygpgme-ptest \
+ python-cryptography-ptest \
"
EXCLUDE_FROM_WORLD = "1"