aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-03-12 15:44:52 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2021-03-17 11:48:07 +0100
commit10c65fc18998d302f34634ffceaf31ab335056dd (patch)
treec24af92cd55cc8f85c0c4c70f82e65ad66df9407 /recipes-core
parent044015255944fd8db139caec8981f2957f8e2604 (diff)
downloadmeta-python2-10c65fc18998d302f34634ffceaf31ab335056dd.tar.gz
recipes: add conditional PNBLACKLIST in all recipes except python-native
* python-native is an exception because there is still e.g. chromium depending on _native_ python and a lot of people use it in some form, once https://bugs.chromium.org/p/chromium/issues/detail?id=942720 is resolved in stable chromium release the same will be set in python-native * https://www.python.org/doc/sunset-python-2/ * https://python3statement.org/ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/meta-python2-image-base.bb2
-rw-r--r--recipes-core/images/meta-python2-image.bb2
-rw-r--r--recipes-core/images/meta-python2-ptest-image.bb2
-rw-r--r--recipes-core/packagegroups/packagegroup-meta-python2.bb2
4 files changed, 8 insertions, 0 deletions
diff --git a/recipes-core/images/meta-python2-image-base.bb b/recipes-core/images/meta-python2-image-base.bb
index 6b43def..834e928 100644
--- a/recipes-core/images/meta-python2-image-base.bb
+++ b/recipes-core/images/meta-python2-image-base.bb
@@ -5,3 +5,5 @@ IMAGE_INSTALL = "packagegroup-core-boot"
LICENSE = "MIT"
inherit core-image
+
+PNBLACKLIST[meta-python2-image-base.bb] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-core/images/meta-python2-image.bb b/recipes-core/images/meta-python2-image.bb
index 9fe75ea..ff3113e 100644
--- a/recipes-core/images/meta-python2-image.bb
+++ b/recipes-core/images/meta-python2-image.bb
@@ -3,3 +3,5 @@ require meta-python2-image-base.bb
SUMMARY = "meta-python2 build test image"
IMAGE_INSTALL += "packagegroup-meta-python2"
+
+PNBLACKLIST[meta-python2-image.bb] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-core/images/meta-python2-ptest-image.bb b/recipes-core/images/meta-python2-ptest-image.bb
index ddf5664..8f9db14 100644
--- a/recipes-core/images/meta-python2-ptest-image.bb
+++ b/recipes-core/images/meta-python2-ptest-image.bb
@@ -3,3 +3,5 @@ require meta-python2-image-base.bb
SUMMARY = "meta-python2 ptest test image"
IMAGE_INSTALL += "packagegroup-meta-python2-ptest"
+
+PNBLACKLIST[meta-python2-ptest-image.bb] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-core/packagegroups/packagegroup-meta-python2.bb b/recipes-core/packagegroups/packagegroup-meta-python2.bb
index 5891cc9..45f2ed7 100644
--- a/recipes-core/packagegroups/packagegroup-meta-python2.bb
+++ b/recipes-core/packagegroups/packagegroup-meta-python2.bb
@@ -89,3 +89,5 @@ RDEPENDS_packagegroup-meta-python2-ptest = "\
"
EXCLUDE_FROM_WORLD = "1"
+
+PNBLACKLIST[packagegroup-meta-python2.bb] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"