aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorMoritz Fischer <moritz.fischer@ettus.com>2017-06-01 09:42:52 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-12 06:56:24 +0200
commit36ef7f234ee61cb917b0e2019e3b77df934a0b73 (patch)
tree2a3fe3a62d412fb342d1c1f46ec11c14e79d6bb8 /recipes-connectivity
parentccce28e9a5c624e2fff6fc5508e38fb5436ca8cd (diff)
downloadmeta-python2-36ef7f234ee61cb917b0e2019e3b77df934a0b73.tar.gz
python-mprpc: Add support for python3
Extend recipe to add support for python3 (From meta-openembedded commit: 894958c35a8694de53aa3fe63b20a431adaec135) Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/python-mprpc/python-mprpc.inc17
-rw-r--r--recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb19
2 files changed, 19 insertions, 17 deletions
diff --git a/recipes-connectivity/python-mprpc/python-mprpc.inc b/recipes-connectivity/python-mprpc/python-mprpc.inc
new file mode 100644
index 0000000..3a1c0be
--- /dev/null
+++ b/recipes-connectivity/python-mprpc/python-mprpc.inc
@@ -0,0 +1,17 @@
+SUMMARY = "A gevent based messagpack rpc library"
+DESCRIPTION = "mprpc is a fast implementation of the messagepack rpc protocol for python. \
+It is based on gevent for handling connections and enabling concurrent connections."
+HOMEPAGE = "https://github.com/studio-ousia/mprpc"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859"
+DEPENDS += "${PYTHON_PN}-gevent"
+RDEPENDS_${PN} += "${PYTHON_PN}-gevent ${PYTHON_PN}-msgpack ${PYTHON_PN}-gsocketpool"
+
+SRC_URI_append = " \
+ file://0001-fix_setup_py.patch;patch=1;pnum=1 \
+"
+
+SRC_URI[md5sum] = "449e6239eb5ff07b9cceb86e1ab0c2ee"
+SRC_URI[sha256sum] = "5881cc7fbb8de814e2b4aa5958bfe147c5c301e46749190f0e6abf373cf56d82"
+
+inherit pypi
diff --git a/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb b/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb
index 78df00a..6b2ea21 100644
--- a/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb
+++ b/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb
@@ -1,17 +1,2 @@
-SUMMARY = "A gevent based messagpack rpc library"
-DESCRIPTION = "mprpc is a fast implementation of the messagepack rpc protocol for python. \
-It is based on gevent for handling connections and enabling concurrent connections."
-HOMEPAGE = "https://github.com/studio-ousia/mprpc"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859"
-DEPENDS += "python-gevent"
-RDEPENDS_${PN} += "python-gevent python-msgpack python-gsocketpool"
-
-SRC_URI_append = " \
- file://0001-fix_setup_py.patch;patch=1;pnum=1 \
-"
-
-SRC_URI[md5sum] = "449e6239eb5ff07b9cceb86e1ab0c2ee"
-SRC_URI[sha256sum] = "5881cc7fbb8de814e2b4aa5958bfe147c5c301e46749190f0e6abf373cf56d82"
-
-inherit pypi setuptools
+require python-mprpc.inc
+inherit setuptools