aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-03-12 15:44:52 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2021-03-17 11:48:07 +0100
commit10c65fc18998d302f34634ffceaf31ab335056dd (patch)
treec24af92cd55cc8f85c0c4c70f82e65ad66df9407 /recipes-connectivity
parent044015255944fd8db139caec8981f2957f8e2604 (diff)
downloadmeta-python2-10c65fc18998d302f34634ffceaf31ab335056dd.tar.gz
recipes: add conditional PNBLACKLIST in all recipes except python-native
* python-native is an exception because there is still e.g. chromium depending on _native_ python and a lot of people use it in some form, once https://bugs.chromium.org/p/chromium/issues/detail?id=942720 is resolved in stable chromium release the same will be set in python-native * https://www.python.org/doc/sunset-python-2/ * https://python3statement.org/ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/gateone/gateone_git.bb2
-rw-r--r--recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.6.bb2
-rw-r--r--recipes-connectivity/python-h2/python-h2_3.1.1.bb2
-rw-r--r--recipes-connectivity/python-hpack/python-hpack_3.0.0.bb2
-rw-r--r--recipes-connectivity/python-hyperframe/python-hyperframe_5.2.0.bb2
-rw-r--r--recipes-connectivity/python-mprpc/python-mprpc_0.1.17.bb2
-rw-r--r--recipes-connectivity/python-networkmanager/python-networkmanager_2.1.bb2
-rw-r--r--recipes-connectivity/python-priority/python-priority_1.3.0.bb2
-rw-r--r--recipes-connectivity/python-pyconnman/python-pyconnman_0.2.0.bb2
-rw-r--r--recipes-connectivity/python-pyro4/python-pyro4_4.77.bb2
-rw-r--r--recipes-connectivity/python-pytun/python-pytun_2.3.0.bb2
-rw-r--r--recipes-connectivity/python-thrift/python-thrift_0.13.0.bb2
-rw-r--r--recipes-connectivity/python-txws/python-txws_0.9.1.bb2
-rw-r--r--recipes-connectivity/telepathy/telepathy-python_0.15.19.bb2
14 files changed, 28 insertions, 0 deletions
diff --git a/recipes-connectivity/gateone/gateone_git.bb b/recipes-connectivity/gateone/gateone_git.bb
index 5d2ca00..83e417c 100644
--- a/recipes-connectivity/gateone/gateone_git.bb
+++ b/recipes-connectivity/gateone/gateone_git.bb
@@ -83,3 +83,5 @@ RDEPENDS_${PN} = "mime-support \
SYSTEMD_SERVICE_${PN} = "gateone.service"
INITSCRIPT_NAME = "gateone"
+
+PNBLACKLIST[gateone] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.6.bb b/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.6.bb
index 6b6e15a..1100dd3 100644
--- a/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.6.bb
+++ b/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.6.bb
@@ -11,3 +11,5 @@ SRC_URI[md5sum] = "49f5f292ef1b60944ae92ca426a5e550"
SRC_URI[sha256sum] = "f2e2749aceadce6b27ca52e2b0a64af99797746a8681e1a2963f72007c14cb14"
inherit pypi setuptools
+
+PNBLACKLIST[python-gsocketpool] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-connectivity/python-h2/python-h2_3.1.1.bb b/recipes-connectivity/python-h2/python-h2_3.1.1.bb
index 33b4c07..efe7ae3 100644
--- a/recipes-connectivity/python-h2/python-h2_3.1.1.bb
+++ b/recipes-connectivity/python-h2/python-h2_3.1.1.bb
@@ -9,3 +9,5 @@ SRC_URI[md5sum] = "950b5a62a2a608dc4547a01edf99aa8f"
SRC_URI[sha256sum] = "b8a32bd282594424c0ac55845377eea13fa54fe4a8db012f3a198ed923dc3ab4"
inherit pypi setuptools
+
+PNBLACKLIST[python-h2] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-connectivity/python-hpack/python-hpack_3.0.0.bb b/recipes-connectivity/python-hpack/python-hpack_3.0.0.bb
index 01bc919..ffeb285 100644
--- a/recipes-connectivity/python-hpack/python-hpack_3.0.0.bb
+++ b/recipes-connectivity/python-hpack/python-hpack_3.0.0.bb
@@ -8,3 +8,5 @@ SRC_URI[md5sum] = "556b0ae66180f54c2ce8029a0952088b"
SRC_URI[sha256sum] = "8eec9c1f4bfae3408a3f30500261f7e6a65912dc138526ea054f9ad98892e9d2"
inherit pypi setuptools
+
+PNBLACKLIST[python-hpack] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-connectivity/python-hyperframe/python-hyperframe_5.2.0.bb b/recipes-connectivity/python-hyperframe/python-hyperframe_5.2.0.bb
index 2ee0487..4d7a055 100644
--- a/recipes-connectivity/python-hyperframe/python-hyperframe_5.2.0.bb
+++ b/recipes-connectivity/python-hyperframe/python-hyperframe_5.2.0.bb
@@ -8,3 +8,5 @@ SRC_URI[md5sum] = "6919183242feb26d8bce3b4cba81defd"
SRC_URI[sha256sum] = "a9f5c17f2cc3c719b917c4f33ed1c61bd1f8dfac4b1bd23b7c80b3400971b41f"
inherit pypi setuptools
+
+PNBLACKLIST[python-hyperframe] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-connectivity/python-mprpc/python-mprpc_0.1.17.bb b/recipes-connectivity/python-mprpc/python-mprpc_0.1.17.bb
index 62cafa8..ed24992 100644
--- a/recipes-connectivity/python-mprpc/python-mprpc_0.1.17.bb
+++ b/recipes-connectivity/python-mprpc/python-mprpc_0.1.17.bb
@@ -12,3 +12,5 @@ SRC_URI[md5sum] = "8d97961051422f3de315613434982d3b"
SRC_URI[sha256sum] = "3589fd127482e291b1ec314d6f0e55cc13311c12932ace356d6178ea1ca28f6a"
inherit pypi setuptools
+
+PNBLACKLIST[python-mprpc] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-connectivity/python-networkmanager/python-networkmanager_2.1.bb b/recipes-connectivity/python-networkmanager/python-networkmanager_2.1.bb
index 53e2f9d..78775e3 100644
--- a/recipes-connectivity/python-networkmanager/python-networkmanager_2.1.bb
+++ b/recipes-connectivity/python-networkmanager/python-networkmanager_2.1.bb
@@ -16,3 +16,5 @@ python() {
if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
raise bb.parse.SkipRecipe('Requires networking-layer to be present to provide networkmanager.')
}
+
+PNBLACKLIST[python-networkmanager] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-connectivity/python-priority/python-priority_1.3.0.bb b/recipes-connectivity/python-priority/python-priority_1.3.0.bb
index 5fdc4db..6aa876d 100644
--- a/recipes-connectivity/python-priority/python-priority_1.3.0.bb
+++ b/recipes-connectivity/python-priority/python-priority_1.3.0.bb
@@ -8,3 +8,5 @@ SRC_URI[md5sum] = "4f1ff52f7fa448e9d9cb46337ae86d1e"
SRC_URI[sha256sum] = "6bc1961a6d7fcacbfc337769f1a382c8e746566aaa365e78047abe9f66b2ffbe"
inherit pypi setuptools
+
+PNBLACKLIST[python-priority] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-connectivity/python-pyconnman/python-pyconnman_0.2.0.bb b/recipes-connectivity/python-pyconnman/python-pyconnman_0.2.0.bb
index 770cc4b..e1f5a14 100644
--- a/recipes-connectivity/python-pyconnman/python-pyconnman_0.2.0.bb
+++ b/recipes-connectivity/python-pyconnman/python-pyconnman_0.2.0.bb
@@ -17,3 +17,5 @@ RDEPENDS_${PN} += "\
python-numbers \
python-pprint \
"
+
+PNBLACKLIST[python-pyconnman] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-connectivity/python-pyro4/python-pyro4_4.77.bb b/recipes-connectivity/python-pyro4/python-pyro4_4.77.bb
index 738cf86..a767779 100644
--- a/recipes-connectivity/python-pyro4/python-pyro4_4.77.bb
+++ b/recipes-connectivity/python-pyro4/python-pyro4_4.77.bb
@@ -16,3 +16,5 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-threading \
${PYTHON_PN}-zlib \
"
+
+PNBLACKLIST[python-pyro4] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-connectivity/python-pytun/python-pytun_2.3.0.bb b/recipes-connectivity/python-pytun/python-pytun_2.3.0.bb
index 2bc6a7c..b7e1e26 100644
--- a/recipes-connectivity/python-pytun/python-pytun_2.3.0.bb
+++ b/recipes-connectivity/python-pytun/python-pytun_2.3.0.bb
@@ -9,3 +9,5 @@ SRC_URI[sha256sum] = "5ead86b3391acef239535ebcabeb04d2cdc6b40ab14580d28c6da193c2
PYPI_PACKAGE = "python-pytun"
inherit pypi setuptools
+
+PNBLACKLIST[python-pytun] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb b/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb
index 2d51619..f3c4bd8 100644
--- a/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb
+++ b/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb
@@ -16,3 +16,5 @@ RDEPENDS_${PN} += "\
${PYTHON_PN}-stringold \
${PYTHON_PN}-threading \
"
+
+PNBLACKLIST[python-thrift] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-connectivity/python-txws/python-txws_0.9.1.bb b/recipes-connectivity/python-txws/python-txws_0.9.1.bb
index f3631cd..c89e769 100644
--- a/recipes-connectivity/python-txws/python-txws_0.9.1.bb
+++ b/recipes-connectivity/python-txws/python-txws_0.9.1.bb
@@ -13,3 +13,5 @@ S = "${WORKDIR}/git"
inherit setuptools
+
+PNBLACKLIST[python-txws] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb b/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb
index b7aea24..640296d 100644
--- a/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb
+++ b/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb
@@ -30,3 +30,5 @@ do_install_append () {
rm -f ${D}${libdir}/python*/site-packages/telepathy/*/*.pyc
rm -f ${D}${libdir}/python*/site-packages/telepathy/*/*.pyo
}
+
+PNBLACKLIST[telepathy-python] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"