aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorMoritz Fischer <moritz.fischer@ettus.com>2017-06-01 09:42:51 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-12 06:56:24 +0200
commitccce28e9a5c624e2fff6fc5508e38fb5436ca8cd (patch)
tree775880b198f79876a571115f9231b929a9268adb /recipes-connectivity
parent0ba30f47b84c3cfa71793672e15669205fbcf448 (diff)
downloadmeta-python2-ccce28e9a5c624e2fff6fc5508e38fb5436ca8cd.tar.gz
python-gsocketpool: Add support for python3
Extend recipe to support python3 (From meta-openembedded commit: dff4ea697125cb743b8ac5ae939394a4f05bf6f8) Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/python-gsocketpool/python-gsocketpool.inc16
-rw-r--r--recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.5.bb18
2 files changed, 18 insertions, 16 deletions
diff --git a/recipes-connectivity/python-gsocketpool/python-gsocketpool.inc b/recipes-connectivity/python-gsocketpool/python-gsocketpool.inc
new file mode 100644
index 0000000..54dd49f
--- /dev/null
+++ b/recipes-connectivity/python-gsocketpool/python-gsocketpool.inc
@@ -0,0 +1,16 @@
+SUMMARY = "A simple connection pool for gevent"
+DESCRIPTION = "creates a pool of connections that can be used with gevent"
+HOMEPAGE = "https://github.com/studio-ousia/gsocketpool"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859"
+DEPENDS += "${PYTHON_PN}-gevent"
+RDEPENDS_${PN} += "${PYTHON_PN}-gevent"
+
+SRC_URI_append = " \
+ file://0001-fix_setup_py.patch;patch=1;pnum=1 \
+"
+
+SRC_URI[md5sum] = "04f618864b18d6b06f774994f172ef49"
+SRC_URI[sha256sum] = "b6b73deab9bcbc428d4813697eebe5c3b9c40a971f62e13607b881aa749af9d0"
+
+inherit pypi
diff --git a/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.5.bb b/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.5.bb
index f86152c..e96ad1c 100644
--- a/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.5.bb
+++ b/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.5.bb
@@ -1,16 +1,2 @@
-SUMMARY = "A simple connection pool for gevent"
-DESCRIPTION = "creates a pool of connections that can be used with gevent"
-HOMEPAGE = "https://github.com/studio-ousia/gsocketpool"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859"
-DEPENDS += "python-gevent"
-RDEPENDS_${PN} += "python-gevent"
-
-SRC_URI_append = " \
- file://0001-fix_setup_py.patch;patch=1;pnum=1 \
-"
-
-SRC_URI[md5sum] = "04f618864b18d6b06f774994f172ef49"
-SRC_URI[sha256sum] = "b6b73deab9bcbc428d4813697eebe5c3b9c40a971f62e13607b881aa749af9d0"
-
-inherit pypi setuptools
+require python-gsocketpool.inc
+inherit setuptools