aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuan Chao <yuanc.fnst@cn.fujitsu.com>2019-09-19 12:23:41 +0900
committerKhem Raj <raj.khem@gmail.com>2019-09-19 00:09:43 -0700
commit9ef570583a144754fa633f3d574aae67ffc25f82 (patch)
tree204c665fcdef0d3e1b5be1a9c764243d01462af7
parent7af572834cf5c81d5da33f14e3746f262486e137 (diff)
downloadmeta-python2-9ef570583a144754fa633f3d574aae67ffc25f82.tar.gz
python-packaging: new recipe
Add new recipe python-packaging as it is RDEPEND of python-pytest. (From meta-openembedded commit: bf73812bc9361fd2e7e7ec47a0175e5d0e339d6c) Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-packaging.inc10
-rw-r--r--recipes-devtools/python/python-packaging_19.2.bb2
2 files changed, 12 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-packaging.inc b/recipes-devtools/python/python-packaging.inc
new file mode 100644
index 0000000..c32caaa
--- /dev/null
+++ b/recipes-devtools/python/python-packaging.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "Core utilities for Python packages"
+HOMEPAGE = "https://github.com/pypa/packaging"
+LICENSE = "Apache-2.0 & BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91"
+
+SRC_URI[md5sum] = "867ce70984dc7b89bbbc3cac2a72b171"
+SRC_URI[sha256sum] = "28b924174df7a2fa32c1953825ff29c61e2f5e082343165438812f00d3a7fc47"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+RDEPENDS_${PN} += "${PYTHON_PN}-six ${PYTHON_PN}-pyparsing"
diff --git a/recipes-devtools/python/python-packaging_19.2.bb b/recipes-devtools/python/python-packaging_19.2.bb
new file mode 100644
index 0000000..55d0746
--- /dev/null
+++ b/recipes-devtools/python/python-packaging_19.2.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-packaging.inc