aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Marie LEMETAYER <jean-marie.lemetayer@savoirfairelinux.com>2019-10-03 16:07:29 +0200
committerKhem Raj <raj.khem@gmail.com>2019-10-04 19:11:55 -0700
commit8e728c6492f5520f4b825060db8ad883d1a27eff (patch)
treef017e2a0af16f5706b91ac542d8d2a4154f4f16c
parent4b3096162bc032a602ee804c2c47c5b2f1d10f08 (diff)
downloadmeta-python2-8e728c6492f5520f4b825060db8ad883d1a27eff.tar.gz
python-toml: add recipes for python2 and python3
This package is a Python library for parsing and creating TOML [1]. Another python TOML parser library named pytoml already exists in meta-oe/recipes-devtools/python/python*-pytoml_*.bb but this library is deprecated and it is explicitly explained to consider using the toml package instead [2]. 1: https://github.com/toml-lang/toml 2: https://github.com/avakar/pytoml/commit/cd2a62e1444cda2c517b02d36b97151acf379b88 (From meta-openembedded commit: a0c79bfccb7a1007b07b26b19df945baed0c7063) Signed-off-by: Jean-Marie LEMETAYER <jean-marie.lemetayer@savoirfairelinux.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-toml.inc10
-rw-r--r--recipes-devtools/python/python-toml_0.10.0.bb6
2 files changed, 16 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-toml.inc b/recipes-devtools/python/python-toml.inc
new file mode 100644
index 0000000..a3b3dfc
--- /dev/null
+++ b/recipes-devtools/python/python-toml.inc
@@ -0,0 +1,10 @@
+SUMMARY = "Python Library for Tom's Obvious, Minimal Language"
+HOMEPAGE = "https://github.com/uiri/toml"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6d6012eea477117abf51c31262a152f8"
+
+SRC_URI[md5sum] = "63fffbe2d632865ec29cd69bfdf36682"
+SRC_URI[sha256sum] = "229f81c57791a41d65e399fc06bf0848bab550a9dfd5ed66df18ce5f05e73d5c"
+
+inherit pypi
diff --git a/recipes-devtools/python/python-toml_0.10.0.bb b/recipes-devtools/python/python-toml_0.10.0.bb
new file mode 100644
index 0000000..3c4acce
--- /dev/null
+++ b/recipes-devtools/python/python-toml_0.10.0.bb
@@ -0,0 +1,6 @@
+inherit setuptools
+require python-toml.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+"