aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2019-09-29 13:42:38 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-30 16:54:51 -0700
commit6d53ee318098711ccc385745a2d3dc307df118c5 (patch)
tree0618dbffacbfcbd0d7896fbd0048eafbb8041803
parentf1aa252b8d3c8422311b096ba15fd9ad6b8c4768 (diff)
downloadmeta-python2-6d53ee318098711ccc385745a2d3dc307df118c5.tar.gz
python-versiontools: add recipes for python2 and python3
python-versiontools is a smart replacement for plain tuple used in __version__. (From meta-openembedded commit: e8a0323766a58fbe0db8ad7e655ee20851774aed) Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-versiontools.inc10
-rw-r--r--recipes-devtools/python/python-versiontools_1.9.1.bb2
2 files changed, 12 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-versiontools.inc b/recipes-devtools/python/python-versiontools.inc
new file mode 100644
index 0000000..b0e696f
--- /dev/null
+++ b/recipes-devtools/python/python-versiontools.inc
@@ -0,0 +1,10 @@
+SUMMARY = "Smart replacement for plain tuple used in __version__"
+SECTION = "devel/python"
+HOMEPAGE = "https://launchpad.net/versiontools"
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=3;endline=20;md5=02193721a38fd8a05a4ddeb7df8e294d"
+
+inherit pypi
+
+SRC_URI[md5sum] = "602b7db8eea30dd29a1d451997adf251"
+SRC_URI[sha256sum] = "a969332887a18a9c98b0df0ea4d4ca75972f24ca94f06fb87d591377e83414f6"
diff --git a/recipes-devtools/python/python-versiontools_1.9.1.bb b/recipes-devtools/python/python-versiontools_1.9.1.bb
new file mode 100644
index 0000000..6bfe82e
--- /dev/null
+++ b/recipes-devtools/python/python-versiontools_1.9.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-versiontools.inc