aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCallaghan, Dan <dan.callaghan@opengear.com>2019-09-25 18:05:37 +1000
committerKhem Raj <raj.khem@gmail.com>2019-09-25 09:48:19 -0700
commit4acbe8b706095aa183f58b8dc14cf03da051c139 (patch)
tree677a3b9410fd076e3becfd0e75c074fa79202db5
parent5629772cb7deda270e5753c8347f5ae1076d8220 (diff)
downloadmeta-python2-4acbe8b706095aa183f58b8dc14cf03da051c139.tar.gz
add new recipes for python-lrparsing, python3-lrparsing
The lrparsing library is an LR(1) parsing library for Python. Grammars can be defined using Python expressions. (From meta-openembedded commit: ef1fbfd0f994f2464d01b3d13b775fb185a0fe58) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-lrparsing.inc16
-rw-r--r--recipes-devtools/python/python-lrparsing_1.0.16.bb2
2 files changed, 18 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-lrparsing.inc b/recipes-devtools/python/python-lrparsing.inc
new file mode 100644
index 0000000..d125151
--- /dev/null
+++ b/recipes-devtools/python/python-lrparsing.inc
@@ -0,0 +1,16 @@
+SUMMARY = "Python LR parsing library"
+SECTION = "devel/python"
+LICENSE = "AGPL-3.0"
+LIC_FILES_CHKSUM = "file://agpl-3.0.txt;md5=73f1eb20517c55bf9493b7dd6e480788"
+
+HOMEPAGE = "http://lrparsing.sourceforge.net/"
+BUGTRACKER = "https://sourceforge.net/p/lrparsing/tickets/"
+UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/lrparsing/files/"
+UPSTREAM_CHECK_REGEX = "lrparsing-(?P<pver>\d+(\.\d+)+)"
+SRC_URI = "${SOURCEFORGE_MIRROR}/lrparsing/lrparsing-${PV}.tar.gz"
+SRC_URI[md5sum] = "34357d69bce87654d792cd8f02d148b2"
+SRC_URI[sha256sum] = "b45afda44001dc5ba632934f74c043d40cce653f1a7526cfbcb68f6be055b8d7"
+
+S = "${WORKDIR}/lrparsing-${PV}"
+
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-lrparsing_1.0.16.bb b/recipes-devtools/python/python-lrparsing_1.0.16.bb
new file mode 100644
index 0000000..2cfe301
--- /dev/null
+++ b/recipes-devtools/python/python-lrparsing_1.0.16.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-lrparsing.inc