aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@foundries.io>2019-09-17 16:09:12 -0300
committerKhem Raj <raj.khem@gmail.com>2019-09-17 20:47:11 -0700
commit25ee52ee1287a1f12fea7286af930960b54be9ba (patch)
treef8415e1c313c1976606e47bb7cd7937833afc690
parente20cf46dc7234ba28f64c77aa99f1f02becaddf2 (diff)
downloadmeta-python2-25ee52ee1287a1f12fea7286af930960b54be9ba.tar.gz
python-pyrsistent: add recipe
Persistent/immutable/functional data structures for python, now required by python-jsonschema. (From meta-openembedded commit: 34709e2d5945950f06d0ea349bb4e6ccefd58781) Signed-off-by: Ricardo Salveti <ricardo@foundries.io> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pyrsistent.inc13
-rw-r--r--recipes-devtools/python/python-pyrsistent_0.15.4.bb2
2 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pyrsistent.inc b/recipes-devtools/python/python-pyrsistent.inc
new file mode 100644
index 0000000..2add037
--- /dev/null
+++ b/recipes-devtools/python/python-pyrsistent.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Persistent/Immutable/Functional data structures for Python"
+HOMEPAGE = "https://github.com/tobgu/pyrsistent"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE.mit;md5=ca574f2891cf528b3e7a2ee570337e7c"
+
+SRC_URI[md5sum] = "0298efae86e009e24136d39dc8b2d33e"
+SRC_URI[sha256sum] = "34b47fa169d6006b32e99d4b3c4031f155e6e68ebcc107d6454852e8e0ee6533"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-six \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/python/python-pyrsistent_0.15.4.bb b/recipes-devtools/python/python-pyrsistent_0.15.4.bb
new file mode 100644
index 0000000..832eb80
--- /dev/null
+++ b/recipes-devtools/python/python-pyrsistent_0.15.4.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-pyrsistent.inc