aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2019-09-29 13:42:39 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-30 16:54:51 -0700
commite7d7d3cef80eb25fb1fa33746a76d63bea9e51a1 (patch)
treec644b9b9959106c97a2db9e1930d66835b05ce34
parent6d53ee318098711ccc385745a2d3dc307df118c5 (diff)
downloadmeta-python2-e7d7d3cef80eb25fb1fa33746a76d63bea9e51a1.tar.gz
python-pymysql: add recipes for python2 and python3
This package contains a pure-Python MySQL client library, based on PEP 249 Most public APIs are compatible with mysqlclient and MySQLdb. (From meta-openembedded commit: a927a361cf05798adee7674f7118e15abc2a9210) Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pymysql.inc18
-rw-r--r--recipes-devtools/python/python-pymysql_0.9.3.bb2
2 files changed, 20 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pymysql.inc b/recipes-devtools/python/python-pymysql.inc
new file mode 100644
index 0000000..8c7f455
--- /dev/null
+++ b/recipes-devtools/python/python-pymysql.inc
@@ -0,0 +1,18 @@
+SUMMARY = "A pure-Python MySQL client library"
+DESCRIPTION = " \
+ This package contains a pure-Python MySQL client library, based on PEP 249 \
+ Most public APIs are compatible with mysqlclient and MySQLdb. \
+ "
+SECTION = "devel/python"
+HOMEPAGE = "https://pymysql.readthedocs.io"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=528175c84163bb800d23ad835c7fa0fc"
+
+SRC_URI[md5sum] = "e5d9183cc0a775ac29f9e0365cca6556"
+SRC_URI[sha256sum] = "d8c059dcd81dedb85a9f034d5e22dcb4442c0b201908bede99e306d65ea7c8e7"
+
+inherit pypi
+
+PYPI_PACKAGE = "PyMySQL"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-cryptography"
diff --git a/recipes-devtools/python/python-pymysql_0.9.3.bb b/recipes-devtools/python/python-pymysql_0.9.3.bb
new file mode 100644
index 0000000..27d097e
--- /dev/null
+++ b/recipes-devtools/python/python-pymysql_0.9.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-pymysql.inc