aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2019-09-29 13:42:41 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-30 16:54:51 -0700
commit5a133ed2ccf3061bb71f5fba8de28cdb783883bc (patch)
tree4699dfd1f18dc7f3323fe51cf5ed3c95c8cfc18d
parent906ebc782690d4da7eded7ca093d3aab0c4aa10b (diff)
downloadmeta-python2-5a133ed2ccf3061bb71f5fba8de28cdb783883bc.tar.gz
python-pyperf: add recipes for python2 and python3
The Python pyperf module is a toolkit to write, run and analyze benchmarks. (From meta-openembedded commit: 1a31f99c612d275642c67c989714c3d24ee18808) Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pyperf.inc23
-rw-r--r--recipes-devtools/python/python-pyperf_1.6.1.bb4
2 files changed, 27 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pyperf.inc b/recipes-devtools/python/python-pyperf.inc
new file mode 100644
index 0000000..81837f3
--- /dev/null
+++ b/recipes-devtools/python/python-pyperf.inc
@@ -0,0 +1,23 @@
+SUMMARY = "A toolkit to write, run and analyze benchmarks"
+DESCRIPTION = " \
+The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
+Features: \
+ * Simple API to run reliable benchmarks \
+ * Automatically calibrate a benchmark for a time budget. \
+ * Spawn multiple worker processes. \
+ * Compute the mean and standard deviation. \
+ * Detect if a benchmark result seems unstable. \
+ * JSON format to store benchmark results. \
+ * Support multiple units: seconds, bytes and integer. \
+"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
+
+SRC_URI[md5sum] = "d67fe5f447963da8873f3e9923f76de1"
+SRC_URI[sha256sum] = "8d0143a22a13ee10c997a648f30b82cdc40175d5a20b11055ae058a82e45d371"
+
+inherit pypi
+
+PYPI_PACKAGE = "pyperf"
+
+DEPENDS += "${PYTHON_PN}-six-native"
diff --git a/recipes-devtools/python/python-pyperf_1.6.1.bb b/recipes-devtools/python/python-pyperf_1.6.1.bb
new file mode 100644
index 0000000..a9d5c74
--- /dev/null
+++ b/recipes-devtools/python/python-pyperf_1.6.1.bb
@@ -0,0 +1,4 @@
+inherit setuptools
+require python-pyperf.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-statistics"