aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2019-09-30 13:11:20 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-30 16:54:51 -0700
commit4b3096162bc032a602ee804c2c47c5b2f1d10f08 (patch)
treeffaa2e28f994906b500498fc615456281bdf3b92
parent45900b1b7ee92497e79b1326032f9d6e6f1cb39b (diff)
downloadmeta-python2-4b3096162bc032a602ee804c2c47c5b2f1d10f08.tar.gz
python-pycurl: add recipes for python2 and python3
PycURL is a Python interface to libcurl, the multiprotocol file transfer library. Similarly to the urllib Python module, PycURL can be used to fetch objects identified by a URL from a Python program (From meta-openembedded commit: 783c4ea997243bb1266a801e0eb317bde908dcf3) Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pycurl.inc26
-rw-r--r--recipes-devtools/python/python-pycurl_7.43.0.3.bb2
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pycurl.inc b/recipes-devtools/python/python-pycurl.inc
new file mode 100644
index 0000000..ac9a370
--- /dev/null
+++ b/recipes-devtools/python/python-pycurl.inc
@@ -0,0 +1,26 @@
+SUMMARY = "A Python Interface To The cURL library"
+DESCRIPTION = "\
+PycURL is a Python interface to libcurl, the multiprotocol file \
+transfer library. Similarly to the urllib Python module, PycURL can \
+be used to fetch objects identified by a URL from a Python program \
+"
+SECTION = "devel/python"
+HOMEPAGE = "http://pycurl.io/"
+
+LICENSE = "LGPLv2 | MIT"
+LIC_FILES_CHKSUM = " \
+ file://COPYING-LGPL;md5=4fbd65380cdd255951079008b364516c \
+ file://COPYING-MIT;md5=2df767ed35d8ea83de4a93feb55e7815 \
+"
+
+SRC_URI[md5sum] = "f0ed4c805e8bec734990e2e0ee78568e"
+SRC_URI[sha256sum] = "6f08330c5cf79fa8ef68b9912b9901db7ffd34b63e225dce74db56bb21deda8e"
+
+inherit pypi
+
+PYPI_PACKAGE = "pycurl"
+
+DEPENDS = "\
+ curl \
+ ${PYTHON_PN}\
+"
diff --git a/recipes-devtools/python/python-pycurl_7.43.0.3.bb b/recipes-devtools/python/python-pycurl_7.43.0.3.bb
new file mode 100644
index 0000000..7ab2592
--- /dev/null
+++ b/recipes-devtools/python/python-pycurl_7.43.0.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-pycurl.inc