aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-09-12 15:49:28 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-12 02:20:59 -0700
commit138c2db89ddd0e87bee5efd3861d2a930773499d (patch)
tree91e68bc315a8ca42631922a4428d14c3c239cc91
parent90ca617ac118620e86bd77894d1d1cda921a318d (diff)
downloadmeta-python2-138c2db89ddd0e87bee5efd3861d2a930773499d.tar.gz
python3-networkx: add recipe
networkx only supports python3 starting v2.3. Move the common code to .inc and remove python-2to3 RDEPENDS which is no longer needed: https://github.com/networkx/networkx/commit/4e611d7ea90c20864daba912d6118220d5bbddf3 (From meta-openembedded commit: ffcd5f58636a7bd07d413ab5c8ee36866718ac19) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-networkx.inc10
-rw-r--r--recipes-devtools/python/python-networkx_2.2.bb10
2 files changed, 13 insertions, 7 deletions
diff --git a/recipes-devtools/python/python-networkx.inc b/recipes-devtools/python/python-networkx.inc
new file mode 100644
index 0000000..a4c31b2
--- /dev/null
+++ b/recipes-devtools/python/python-networkx.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "Python package for creating and manipulating graphs and networks"
+LICENSE = "BSD-3-Clause"
+
+inherit pypi
+
+PYPI_PACKAGE_EXT = "zip"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-decorator \
+ "
diff --git a/recipes-devtools/python/python-networkx_2.2.bb b/recipes-devtools/python/python-networkx_2.2.bb
index a238166..648f031 100644
--- a/recipes-devtools/python/python-networkx_2.2.bb
+++ b/recipes-devtools/python/python-networkx_2.2.bb
@@ -1,12 +1,8 @@
-DESCRIPTION = "Python package for creating and manipulating graphs and networks"
-LICENSE = "BSD-3-Clause"
+require python-networkx.inc
+
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3376ff7c9c58048c62d91431f7f08cde"
SRC_URI[md5sum] = "82608a3686fb3e61f20cf13bfd3c1b4a"
SRC_URI[sha256sum] = "45e56f7ab6fe81652fb4bc9f44faddb0e9025f469f602df14e3b2551c2ea5c8b"
-PYPI_PACKAGE_EXT = "zip"
-
-inherit pypi setuptools
-
-RDEPENDS_${PN} += "python-2to3"
+inherit setuptools