aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2019-04-09 09:00:19 +0800
committerKhem Raj <raj.khem@gmail.com>2019-04-09 21:31:36 -0700
commit96aec11f18a009335adb18674ddacf0c04bbca0c (patch)
treeaa773bdd69cd3a55a477b65d44ec9f1ac1e7d721
parent679a4f63e49c1213d070c8668fa241944eaa3afd (diff)
downloadmeta-python2-96aec11f18a009335adb18674ddacf0c04bbca0c.tar.gz
python-flask-socketio: move to meta-python directory
The previous commits put the python-engineio, python-socketio and python-flask-socketio to a wrong directory. Move them to meta-python. (From meta-openembedded commit: 3cabe2feebe628003c626fee5a09c88e647705c2) Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-engineio.inc13
-rw-r--r--recipes-devtools/python/python-engineio_3.5.0.bb2
-rw-r--r--recipes-devtools/python/python-flask-socketio.inc18
-rw-r--r--recipes-devtools/python/python-flask-socketio_3.3.2.bb2
-rw-r--r--recipes-devtools/python/python-socketio.inc17
-rw-r--r--recipes-devtools/python/python-socketio_4.0.0.bb2
6 files changed, 54 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-engineio.inc b/recipes-devtools/python/python-engineio.inc
new file mode 100644
index 0000000..c399d7d
--- /dev/null
+++ b/recipes-devtools/python/python-engineio.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Engine.IO server"
+HOMEPAGE = "https://github.com/miguelgrinberg/python-engineio/"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=42d0a9e728978f0eeb759c3be91536b8"
+
+inherit pypi
+
+PYPI_PACKAGE = "python-engineio"
+
+SRC_URI[md5sum] = "011a61f1ee84755043cf862c8cc24f21"
+SRC_URI[sha256sum] = "b2756ce53076163eb24f59c1d1a903ac72f071ad4fb7b3ef6dab1b1b9ae9a44f"
diff --git a/recipes-devtools/python/python-engineio_3.5.0.bb b/recipes-devtools/python/python-engineio_3.5.0.bb
new file mode 100644
index 0000000..7dd6ec0
--- /dev/null
+++ b/recipes-devtools/python/python-engineio_3.5.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-engineio.inc
diff --git a/recipes-devtools/python/python-flask-socketio.inc b/recipes-devtools/python/python-flask-socketio.inc
new file mode 100644
index 0000000..251d13e
--- /dev/null
+++ b/recipes-devtools/python/python-flask-socketio.inc
@@ -0,0 +1,18 @@
+SUMMARY = "Socket.IO integration for Flask applications"
+HOMEPAGE = "https://github.com/miguelgrinberg/Flask-SocketIO/"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=38cc21254909604298ce763a6e4440a0"
+
+inherit pypi
+
+PYPI_PACKAGE = "Flask-SocketIO"
+
+SRC_URI[md5sum] = "298965a43f6534e8a5b24d1ba1fc4186"
+SRC_URI[sha256sum] = "8d8f9f104db5ddff1b06ba322d8e158881d590144199c993fe26cf53218c7edd"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-flask \
+ ${PYTHON_PN}-socketio \
+ "
diff --git a/recipes-devtools/python/python-flask-socketio_3.3.2.bb b/recipes-devtools/python/python-flask-socketio_3.3.2.bb
new file mode 100644
index 0000000..3b9ad33
--- /dev/null
+++ b/recipes-devtools/python/python-flask-socketio_3.3.2.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-flask-socketio.inc
diff --git a/recipes-devtools/python/python-socketio.inc b/recipes-devtools/python/python-socketio.inc
new file mode 100644
index 0000000..a23e780
--- /dev/null
+++ b/recipes-devtools/python/python-socketio.inc
@@ -0,0 +1,17 @@
+SUMMARY = "Socket.IO server"
+HOMEPAGE = "https://github.com/miguelgrinberg/python-socketio/"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=42d0a9e728978f0eeb759c3be91536b8"
+
+inherit pypi
+
+PYPI_PACKAGE = "python-socketio"
+
+SRC_URI[md5sum] = "0b57da61a9464d2e0dc9a8d0164d86d2"
+SRC_URI[sha256sum] = "64feb0817f1bf7e3e7fc05f6f65e28d76146d8061cb7de25b63502717f80e908"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-engineio \
+ "
diff --git a/recipes-devtools/python/python-socketio_4.0.0.bb b/recipes-devtools/python/python-socketio_4.0.0.bb
new file mode 100644
index 0000000..e25a6b3
--- /dev/null
+++ b/recipes-devtools/python/python-socketio_4.0.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-socketio.inc