aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2019-03-28 14:21:33 +0800
committerKhem Raj <raj.khem@gmail.com>2019-03-28 11:56:25 -0700
commit1cba5b9dca06a60b1929ab0dc0c538c924a3a514 (patch)
tree7da3158b2885227d824e95d9b0ed74754511a471
parent3fece6ed1906c9976dbc9bb0e4b707917898fb08 (diff)
downloadmeta-python2-1cba5b9dca06a60b1929ab0dc0c538c924a3a514.tar.gz
python-tqdm: add recipe
(From meta-openembedded commit: a88f90fb8de86adbca8e7a65a510899bd0929b48) Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-tqdm.inc13
-rw-r--r--recipes-devtools/python/python-tqdm_4.31.1.bb2
2 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-tqdm.inc b/recipes-devtools/python/python-tqdm.inc
new file mode 100644
index 0000000..967a80c
--- /dev/null
+++ b/recipes-devtools/python/python-tqdm.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Fast, Extensible Progress Meter"
+HOMEPAGE = "http://tqdm.github.io/"
+SECTION = "devel/python"
+
+LICENSE = "MIT & MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=054ef7105cba050017d1368262a1623c"
+
+inherit pypi
+
+SRC_URI[md5sum] = "807e8c13e16e3660ac88e05d711daeb0"
+SRC_URI[sha256sum] = "e22977e3ebe961f72362f6ddfb9197cc531c9737aaf5f607ef09740c849ecd05"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/python/python-tqdm_4.31.1.bb b/recipes-devtools/python/python-tqdm_4.31.1.bb
new file mode 100644
index 0000000..b381009
--- /dev/null
+++ b/recipes-devtools/python/python-tqdm_4.31.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-tqdm.inc