aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2019-03-28 14:21:34 +0800
committerKhem Raj <raj.khem@gmail.com>2019-03-28 11:56:25 -0700
commit6d6c9641ef38ae54abc8f1279fd80ad2b2df4567 (patch)
treebcab4de1bfe88c705f81e2b4714e5e9b79ac1c1c
parent1cba5b9dca06a60b1929ab0dc0c538c924a3a514 (diff)
downloadmeta-python2-6d6c9641ef38ae54abc8f1279fd80ad2b2df4567.tar.gz
python-cachetools: add recipe
(From meta-openembedded commit: d2b4866919d6f0b2c9b979c981a0b937a208ac74) Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-cachetools.inc16
-rw-r--r--recipes-devtools/python/python-cachetools_3.1.0.bb2
2 files changed, 18 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-cachetools.inc b/recipes-devtools/python/python-cachetools.inc
new file mode 100644
index 0000000..52ae318
--- /dev/null
+++ b/recipes-devtools/python/python-cachetools.inc
@@ -0,0 +1,16 @@
+SUMMARY = "Extensible memoizing collections and decorators"
+HOMEPAGE = "https://github.com/tkem/cachetools"
+DESCRIPTION = "This module provides various memoizing \
+collections and decorators, including variants of the \
+Python 3 Standard Library @lru_cache function decorator."
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=27f7518eb6f7dc686d0f953b2f28dae5"
+
+inherit pypi
+
+SRC_URI[md5sum] = "a7b1c5eb5390d50067c62d7bcb4e875c"
+SRC_URI[sha256sum] = "9efcc9fab3b49ab833475702b55edd5ae07af1af7a4c627678980b45e459c460"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/python/python-cachetools_3.1.0.bb b/recipes-devtools/python/python-cachetools_3.1.0.bb
new file mode 100644
index 0000000..8c12ad0
--- /dev/null
+++ b/recipes-devtools/python/python-cachetools_3.1.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-cachetools.inc