aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorleimaohui <leimaohui@cn.fujitsu.com>2019-04-16 15:42:24 +0800
committerKhem Raj <raj.khem@gmail.com>2019-04-16 21:07:25 -0700
commit18e07b09e59b3709fc34ac6a3b6de353a106e0ec (patch)
tree44f10a59134199fc9bcebeabd3e4dc5c8af0cc99
parent0d916339643665f0125fcefb336c56cf5fe69612 (diff)
downloadmeta-python2-18e07b09e59b3709fc34ac6a3b6de353a106e0ec.tar.gz
python-pycodestyle: Fix conflict error with python3-pycodestyle during do_rootfs
(From meta-openembedded commit: 13223cc7007981c5169e9a54402600de177ea131) Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pycodestyle_2.4.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pycodestyle_2.4.0.bb b/recipes-devtools/python/python-pycodestyle_2.4.0.bb
index 7c736e7..ec6c12f 100644
--- a/recipes-devtools/python/python-pycodestyle_2.4.0.bb
+++ b/recipes-devtools/python/python-pycodestyle_2.4.0.bb
@@ -2,3 +2,9 @@ inherit setuptools
require python-pycodestyle.inc
RDEPENDS_${PN} += "${PYTHON_PN}-lang"
+
+do_install_append () {
+ if [ -f ${D}${bindir}/pycodestyle ]; then
+ mv ${D}${bindir}/pycodestyle ${D}${bindir}/pycodestyle-2
+ fi
+}