aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2018-08-29 13:14:56 +0300
committerKhem Raj <raj.khem@gmail.com>2018-08-29 18:18:14 -0700
commitc83caa40ab0717fd6cd7df9a456725ef3d1f8534 (patch)
treef7f3dc2a50587db58a8b89c8525e76aa65eb22a9
parent0cc1845de3ea3eaa0fb6c37a3ff2e523fd490999 (diff)
downloadmeta-python2-c83caa40ab0717fd6cd7df9a456725ef3d1f8534.tar.gz
python3-pytest-helpers-namespace: add recipe
(From meta-openembedded commit: 00deeeec3bd138d585382e542c0bfca91204fb61) Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-pytest-helpers-namespace.inc10
-rw-r--r--recipes-devtools/python/python-pytest-helpers-namespace_2016.7.10.bb11
2 files changed, 12 insertions, 9 deletions
diff --git a/recipes-devtools/python/python-pytest-helpers-namespace.inc b/recipes-devtools/python/python-pytest-helpers-namespace.inc
new file mode 100644
index 0000000..a69867d
--- /dev/null
+++ b/recipes-devtools/python/python-pytest-helpers-namespace.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "This plugin does not provide any helpers to pytest, it does, however, provide a helpers namespace in pytest which enables you to register helper functions in your conftest.py to be used within your tests without having to import them."
+HOMEPAGE = "https://github.com/saltstack/pytest-helpers-namespace"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=71fac4dfeee99c39c51f617e9486237c"
+
+SRC_URI[md5sum] = "80fe3e515f640b1459709b539f6b857e"
+SRC_URI[sha256sum] = "d8bdb017c0f7271699c08850b6b12e1ce9e52913cbd4461b5febd21082a29113"
+
+inherit pypi
diff --git a/recipes-devtools/python/python-pytest-helpers-namespace_2016.7.10.bb b/recipes-devtools/python/python-pytest-helpers-namespace_2016.7.10.bb
index afca487..2b6ee85 100644
--- a/recipes-devtools/python/python-pytest-helpers-namespace_2016.7.10.bb
+++ b/recipes-devtools/python/python-pytest-helpers-namespace_2016.7.10.bb
@@ -1,13 +1,6 @@
-DESCRIPTION = "This plugin does not provide any helpers to pytest, it does, however, provide a helpers namespace in pytest which enables you to register helper functions in your conftest.py to be used within your tests without having to import them."
-HOMEPAGE = "https://github.com/saltstack/pytest-helpers-namespace"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://PKG-INFO;md5=71fac4dfeee99c39c51f617e9486237c"
+require python-pytest-helpers-namespace.inc
-SRC_URI[md5sum] = "80fe3e515f640b1459709b539f6b857e"
-SRC_URI[sha256sum] = "d8bdb017c0f7271699c08850b6b12e1ce9e52913cbd4461b5febd21082a29113"
-
-inherit pypi setuptools
+inherit setuptools
RDEPENDS_${PN} += " \
python-pytest \